计算机学院大学生程序设计竞赛(2015’12)Happy Value(最大生成树)

21 篇文章 0 订阅

Happy Value

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1350    Accepted Submission(s): 400


Problem Description
In an apartment, there are N residents. The Internet Service Provider (ISP) wants to connect these residents with N – 1 cables. 
However, the friendships of the residents are different. There is a “Happy Value” indicating the degrees of a pair of residents. The higher “Happy Value” is, the friendlier a pair of residents is. So the ISP wants to choose a connecting plan to make the highest sum of “Happy Values”.
 

Input
There are multiple test cases. Please process to end of file.
For each case, the first line contains only one integer N (2<=N<=100), indicating the number of the residents.
Then N lines follow. Each line contains N integers. Each integer H ij(0<=H ij<=10000) in i th row and j th column indicates that i th resident have a “Happy Value” H ijwith j th resident. And H ij(i!=j) is equal to H ji. H ij(i=j) is always 0.
 

Output
For each case, please output the answer in one line.
 

Sample Input
  
  
2 0 1 1 0 3 0 1 5 1 0 3 5 3 0
 

Sample Output
  
  
1 8
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <list>
#define LL long long
#define INF 0x3f3f3f3f

using namespace std;

int h[110][110];
int eveco[110];
bool vis[110];
int Pri(int n)
{
    memset(vis,false,sizeof(vis));
    for(int i=1;i<=n;i++)
        eveco[i] = h[1][i];
    int cost = 0;
    vis[1] = true;
    eveco[1] = 0;
    for(int i=1;i<n;i++)
    {
        int m = 0,pos;
        for(int j=1;j<=n;j++)
        {
            if(m < eveco[j] && !vis[j])
                pos = j, m= eveco[j];
        }
        cost += m;
        vis[pos] = true;
        for(int j=1;j<=n;j++)
            if(!vis[j] && eveco[j] < h[pos][j])
            eveco[j] = h[pos][j];
    }
    return cost;
}


int main()
{
    int n;
    while(cin>>n)
    {
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                cin>>h[i][j];
            }
        }
        cout<<Pri(n)<<endl;
    }
    return 0;
}



  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值