uva 11806 容斥原理+dfs

 

In most professional sporting events, cheerleaders play a major role in entertaining the spectators. Their roles are substantial during breaks and prior to start of play. The world cup soccer is no exception. Usually the cheerleaders form a group and perform at the centre of the field. In addition to this group, some of them are placed outside the side line so they are closer to the spectators. The organizers would like to ensure that at least one cheerleader is located on each of the four sides. For this problem, we will model the playing ground as an M*N rectangular grid. The constraints for placing cheerleaders are described below:

 

  • There should be at least one cheerleader on each of the four sides. Note that, placing a cheerleader on a corner cell would cover two sides simultaneously.
  • There can be at most one cheerleader in a cell.
  • All the cheerleaders available must be assigned to a cell. That is, none of them can be left out.

 

 

 

The organizers would like to know, how many ways they can place the cheerleaders while maintaining the above constraints. Two placements are different, if there is at least one cell which contains a cheerleader in one of the placement but not in the other. 

 

 

 

Input

 

The first line of input contains a positive integer T<=50, which denotes the number of test cases. T lines then follow each describing one test case. Each case consists of three nonnegative integers, 2<=M, N<=20 and K<=500. Here M is the number of rows and N is the number of columns in the grid. K denotes the number of cheerleaders that must be assigned to the cells in the grid.

 

 

Output

 

For each case of input, there will be one line of output. It will first contain the case number followed by the number of ways to place the cheerleaders as described earlier. Look at the sample output for exact formatting. Note that, the numbers can be arbitrarily large. Therefore you must output the answers modulo 1000007.

Sample Input

2

2 3 1

2 3 2

Sample Output

Case 1: 0

Case 2: 2

题目大意:在一个n*m的网格放k个想同的石子,每个格子最多放一块,都要放玩,求第一行、最后一行、第一列、最后一列、都得有石子的种数

直接求太麻烦了,运用容斥原理设集合S、A(第一行没有石子)、B(第一列没有石子)、C(最后一行没有石子)、D(最后一列没有石子)

设题目要求的结合为E(第一行、最后一行、第一列、最后一列、都得有石子)

设A'为A的补集,设A&B为A跟B的交集(数学符号懒得找,就用这种表示了)

那么根据容斥原理

E=A'&B'&C'&D'=S-(A+B+C+D)+(A&B+A&C+A&D+B&C+B&D+C&D)-(A&B&C+A&B&D+A&C&D+B&C&D)+A&B&C&D

用dfs做容斥原理

AC代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define Max 550
#define MOD 1000007
int c[Max][Max];
int map[5]={0,1,2,3,4};
int vis[5];
int n,m,k,num,temp;

void Init()
{
    memset(c,0,sizeof(c));
    int i,j;
    for(i=0;i<Max;i++)
    {
        for(j=0;j<=i;j++)
        {
            if(j==0)
                c[i][j]=1;
            else 
                c[i][j]=(c[i-1][j]+c[i-1][j-1])%MOD;
        }
    }
}

void dfs(int now,int top,int start,int s)
{
    int a,b;
    a=n;
    b=m;
    if(now==top)
    {
        while(s%10)
        {
            if((s%10)%2)
                a--;
            else 
                b--;
            s/=10;
        }
        num=(num+MOD+temp*c[a*b][k])%MOD;
        return ;
    }
    for(int j=start;j<=4;j++)
    {
        if(!vis[j])
        {
            vis[j]=true;
            int s1=s*10+j;
            dfs(now+1,top,j+1,s1);
            vis[j]=false;
        }
    }
    return ;
}
int main()
{
    Init();
    int t,sum,i,Case;
    cin>>t;
    Case=0;
    while(t--)
    {
        Case++;
        cin>>n>>m>>k;
        sum=c[n*m][k];
        memset(vis,false,sizeof(vis));
        for(i=1;i<=4;i++)
        {
            num=0;
            temp=(i%2?-1:1);
            dfs(0,i,1,0);
            sum=(sum+MOD+num)%MOD;
        }
        printf("Case %d: %d\n",Case,sum);
    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/xiong-/p/3209878.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值