POJ1651 Multiplication Puzzle 区间DP

Multiplication Puzzle

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14834 Accepted: 9107

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

题目大意

给定你一个序列,其中取走一个数的代价是它乘上它相邻的两个数

两头的数不可以取~

求最小代价

状态转移方程:

设状态函数dp[i][j],表示从第i个数到第j个数抽取完后的最小值。一开始初始化为3个数,就只有3个数相乘。后面长度从3增加到n,则状态转移方程为

dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+a[i]*a[k]*a[j])     (i<k<j)其中k表示在i...j中最后抽的牌是a[k].

#include<iostream>
#include<string.h>
#include<string>
#include<math.h>
using namespace std;
int a[105],dp[105][105];//dp表示从第i个数到第j个数抽取完后的最小值
int n;
int main()
{
    cin>>n;
    for(int i=1;i<=n;i++)
        cin>>a[i];
    for(int i=1;i+1<n;i++)//初始化
        dp[i][i+2]=a[i]*a[i+1]*a[i+2];
    for(int len=4;len<=n;len++)
    {
        for(int i=1;i+len-1<=n;i++)
        {
            int j=i+len-1;
            dp[i][j]=99999999;  
            for(int k=i+1;k<j;k++)//其中k表示在i...j中最后抽的牌是a[k].
                dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]+a[k]*a[i]*a[j]);
        }
    }
    cout<<dp[1][n]<<endl;
    return 0;

}

 

转载于:https://www.cnblogs.com/-citywall123/p/10901891.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值