uva11237

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certaintotal number of sweets on that day, no matter how many children call on him, so it may happen thata child will get nothing if it is too late. To avoid conflicts, the children have decided they will putall sweets together and then divide them evenly among themselves. From last year’s experience ofHalloween they know how many sweets they get from each neighbour. Since they care more aboutjustice than about the number of sweets they get, they want to select a subset of the neighbours tovisit, so that in sharing every child receives the same number of sweets. They will not be satisfied ifthey have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number ofchildren and the number of neighbours, respectively. The next line contains n space separated integersa1, . . . , an (1 ≤ ai ≤ 100000), where ai represents the number of sweets the children get if they visitneighbour i.The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here,index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution whereeach child gets at least one sweet, print ‘no sweets’ instead. Note that if there are several solutionswhere each child gets at least one sweet, you may print any of them.

Sample Input

4 5

1 2 3 7 5

3 6

7 11 2 5 13 17

0 0

Sample Output

3 5

2 3 4


由抽屉原理可以证明一定有情况成立!

这题被学长坑的呀!给的代码怎么写都错!还不如自己想办法写!只要思想没受束缚这题应该还是挺好过的。毕竟随机输出一组数据就行了。


#include <iostream>
#include<stdio.h>
#include<memory.h>
#include<algorithm>
using namespace std;
struct data0
{
    int mod,i;
}sum[100010];

struct data
{
    int num,i;
}mod[100010];
bool cmp(data a,data b)
{
    return a.num>b.num;
}
int main()
{
    int c,n;
    while(~scanf("%d%d",&c,&n)&&!(c==0&&n==0))
    {
       memset(sum,0,sizeof(sum));
       memset(mod,0,sizeof(mod));
       int x=100000000;
       for(int i=0;i<n;i++)
       {
           mod[i].i=i;
           sum[i].i=i;
           int y;
           scanf("%d",&y);
           if(i==0)
           sum[i].mod=y%c;
           else sum[i].mod=(sum[i-1].mod+y)%c;
           if(sum[i].mod==0)
               x=min(x,i);
            mod[sum[i].mod].num++;
       }
       if(x!=100000000)
       {
           for(int i=0;i<=x;i++)
           printf("%d ",i+1);
           printf("\n");continue;
       }
           int flag=0;
        sort(mod,mod+n,cmp);
        int s=0,e=0;
        for(int i=0;i<n;i++)
        {
            if(flag==0&&sum[i].mod==mod[0].i)
            {
                s=sum[i].i;flag=1;
            }else if(flag==1&&sum[i].mod==mod[0].i)
            {
                e=sum[i].i;break;
            }
        }
            if(s>e)swap(s,e);

          // if(flag==0)
         //  {
          //     printf("no sweets\n");
         //  }
           //else
          // {
            for(int i=s+1;i<=e;i++)
            printf("%d ",i+1);
            printf("\n");
         //  }
    }
    return 0;
}

转载于:https://www.cnblogs.com/martinue/p/5490553.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值