UVA - 10129Play on Words(欧拉路)

UVA - 10129Play on Words

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve
it to open that doors. Because there is no other way to open the doors, the puzzle is very important
for us.
There is a large number of magnetic plates on every door. Every plate has one word written on
it. The plates must be arranged into a sequence in such a way that every word begins with the same
letter as the previous word ends. For example, the word ‘acm’ can be followed by the word ‘motorola’.
Your task is to write a computer program that will read the list of words and determine whether it
is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to
open the door.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file.
Each test case begins with a line containing a single integer number N that indicates the number of
plates (1 ≤ N ≤ 100000). Then exactly N lines follow, each containing a single word. Each word
contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will
appear in the word. The same word may appear several times in the list.
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that
the first letter of each word is equal to the last letter of the previous word. All the plates from the
list must be used, each exactly once. The words mentioned several times must be used that number of
times.
If there exists such an ordering of plates, your program should print the sentence ‘Ordering is
possible.’. Otherwise, output the sentence ‘The door cannot be opened.’
Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.

题解:让判断一组字符串能否排成收尾字母相等的顺序,注意要判断入度出度差不能大于等于2;剩下的就是欧拉路的判断;

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
#define mem(x,y) memset(x,y,sizeof(x))
#define SI(x) scanf("%d",&x)
#define PI(x) printf("%d",x)
#define P_ printf(" ")
const int INF=0x3f3f3f3f;
typedef long long LL;
int pre[30];
int que[30];
int in[30],out[30];
void initial(){
	mem(pre,-1);mem(que,0);mem(in,0);mem(out,0);
}
int find(int x){
	return pre[x]=x==pre[x]?x:find(pre[x]);
}
void merge(int x,int y){
	int f1,f2;
	if(pre[x]==-1)pre[x]=x;
	if(pre[y]==-1)pre[y]=y;
	f1=find(x);f2=find(y);
	if(f1!=f2){
		pre[f1]=f2;
	}
}
int main(){
	int T,N,a,b;
	char s[1010];
	SI(T);
	while(T--){
		initial();
		SI(N);
		for(int i=0;i<N;i++){
			scanf("%s",s);
			int len=strlen(s);
			a=s[0]-'a';
			b=s[len-1]-'a';
			que[a]++;que[b]++;
			in[a]++;out[b]++;
			merge(a,b);
		}
		int flot=0,cnt=0,ok=1,x1=0,x2=0;
		for(int i=0;i<26;i++){
			if(pre[i]==-1)continue;
			if(que[i]%2==1)cnt++;
			if(pre[i]==i)flot++;
			if(abs(in[i]-out[i])>=2)ok=0;
		}
		if(ok&&flot==1&&(cnt==0||cnt==2))puts("Ordering is possible.");
		else{
			printf("The door cannot be opened.\n");
		}
	}
	return 0;
}

  

转载于:https://www.cnblogs.com/handsomecui/p/5099074.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值