hdu1516-String Distance and Transform Process(编辑距离)

String Distance is a non-negative integer that measures the distance between two strings. Here we give the definition. A transform list is a list of string, where each string, except for the last one, can be changed to the string followed by adding a character, deleting a character or replacing a character. The length of a transform list is the count of strings minus 1 (that is the count of operations to transform these two strings). The distance between two strings is the length of a transform list from one string to the other with the minimal length. You are to write a program to calculate the distance between two strings and give the corresponding transform list.

Input

Input consists a sequence of string pairs, each string pair consists two lines, each string occupies one line. The length of each string will be no more than 80. 

Output

For each string pair, you should give an integer to indicate the distance between them at the first line, and give a sequence of command to transform string 1 to string 2. Each command is a line lead by command count, then the command. A command must be 

Insert pos,value 
Delete pos 
Replace pos,value 

where pos is the position of the string and pos should be between 1 and the current length of the string (in Insert command, pos can be 1 greater than the length), and value is a character. Actually many command lists can satisfy the request, but only one of them is required. 

Sample Input

abcac
bcd
aaa
aabaaaa

Sample Output

3
1 Delete 1
2 Replace 3,d
3 Delete 4
4
1 Insert 1,a
2 Insert 2,a
3 Insert 3,b
4 Insert 7,a

AC:

#include<iostream>
#include<cstdio>
#include<cstring>
#define maxn 100
using namespace std;

char str[maxn],ctr[maxn];
int dp[maxn][maxn],lena,lenb;

void print()
{
    int step=0,tmp,a=lena,b=lenb;
    while(a>=1||b>=1)
    {
        if(str[a-1]==ctr[b-1]) tmp=0;
        else tmp=1;
        if(dp[a][b]==dp[a-1][b-1]+tmp&&a>=1&&b>=1)
        {
            if(tmp)
                printf("%d Replace %d,%c\n",++step,a,ctr[b-1]);
            a--,b--;
        }
        else if(dp[a][b]==dp[a-1][b]+1&&a>=1)
        {
            printf("%d Delete %d\n",++step,a);
			a--;
        }
        else if(dp[a][b]==dp[a][b-1]+1&&b>=1)
        {
            printf("%d Insert %d,%c\n",++step,a+1,ctr[b-1]);
			b--;
        }
    }
}

int main()
{
    while(scanf("%s %s",str,ctr)!=EOF)
    {
        getchar();
        lena=strlen(str);
        lenb=strlen(ctr);
        memset(dp,0,sizeof(dp));

        for(int i=0;i<=lena;i++)
            dp[i][0]=i;
        for(int i=0;i<=lenb;i++)
            dp[0][i]=i;
        for(int i=1;i<=lena;i++)
            for(int j=1;j<=lenb;j++)
            {
                int tmp=min(dp[i-1][j],dp[i][j-1])+1;
                int d=str[i-1]==ctr[j-1]?0:1;
                dp[i][j]=min(tmp,dp[i-1][j-1]+d);
            }
        printf("%d\n",dp[lena][lenb]);
        print();
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/wangtao971115/p/10358317.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值