hdu1516(字符串距离+输出路径)

String Distance and Transform Process

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 447    Accepted Submission(s): 222
Special Judge


Problem Description
String Distance is a non-negative integer that measures the distance between two strings. Here we give the definition. A transform list is a list of string, where each string, except for the last one, can be changed to the string followed by adding a character, deleting a character or replacing a character. The length of a transform list is the count of strings minus 1 (that is the count of operations to transform these two strings). The distance between two strings is the length of a transform list from one string to the other with the minimal length. You are to write a program to calculate the distance between two strings and give the corresponding transform list.
 

Input
Input consists a sequence of string pairs, each string pair consists two lines, each string occupies one line. The length of each string will be no more than 80.
 

Output
For each string pair, you should give an integer to indicate the distance between them at the first line, and give a sequence of command to transform string 1 to string 2. Each command is a line lead by command count, then the command. A command must be

Insert pos,value
Delete pos
Replace pos,value

where pos is the position of the string and pos should be between 1 and the current length of the string (in Insert command, pos can be 1 greater than the length), and value is a character. Actually many command lists can satisfy the request, but only one of them is required.
 

Sample Input
  
  
abcac bcd aaa aabaaaa
 

Sample Output
  
  
3 1 Delete 1 2 Replace 3,d 3 Delete 4 4 1 Insert 1,a 2 Insert 2,a 3 Insert 3,b 4 Insert 7,a
题意是说求出字符串的最短路径,并且打印出路径

路径可以用字符串路径算法求出,字符串距离算法

代码:

#include <bits/stdc++.h>
using namespace std;
const int maxn=1000+5;
char s[maxn],t[maxn];
int dp[maxn][maxn];
//表示a长度为maxn时装换到长度为maxn的b所需的最短操作
int n,m;
void input()
{

}
void solve()
{
    n=strlen(s),m=strlen(t);
    for(int i=0;i<=n;i++)
        dp[i][0]=i;
    for(int i=0;i<=m;i++)
        dp[0][i]=i;
    for(int i=1;i<=n;i++)
    for(int j=1;j<=m;j++){
        dp[i][j]=min(dp[i-1][j],dp[i][j-1])+1;
        dp[i][j]=min(dp[i][j],dp[i-1][j-1]+(s[i-1]!=t[j-1]));
    }
}

void output()
{
    printf("%d\n",dp[n][m]);

    int i=strlen(s),j=strlen(t);
    int step=0;
    int temp;
    while(i>=1||j>=1){
        if(s[i-1]!=t[j-1])
            temp=1;
        else
            temp=0;
        if(dp[i][j]==(dp[i-1][j-1]+temp)&&i>=1&&j>=1){
            if(temp)
                printf("%d Replace %d,%c\n",++step,i,t[j-1]);
            i--,j--;
        }else
        if(dp[i][j]==(dp[i][j-1]+1)&&j>=1){
            printf("%d Insert %d %c\n",++step,i+1,t[j-1]);
            j--;
        }else
        if(dp[i][j]==(dp[i-1][j]+1)&&i>=1){
            printf("%d Delete %d\n",++step,i);
            i--;
        }
    }

}
int main()
{
    while(~scanf("%s%s",s,t)){

        solve();
        output();
    }

    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值