杭电acm之1516--String Distance and Transform Process

Problem Description
String Distance is a non-negative integer that measures the distance between two strings. Here we give the definition. A transform list is a list of string, where each string, except for the last one, can be changed to the string followed by adding a character, deleting a character or replacing a character. The length of a transform list is the count of strings minus 1 (that is the count of operations to transform these two strings). The distance between two strings is the length of a transform list from one string to the other with the minimal length. You are to write a program to calculate the distance between two strings and give the corresponding transform list.
 

Input
Input consists a sequence of string pairs, each string pair consists two lines, each string occupies one line. The length of each string will be no more than 80.
 

Output
For each string pair, you should give an integer to indicate the distance between them at the first line, and give a sequence of command to transform string 1 to string 2. Each command is a line lead by command count, then the command. A command must be

Insert pos,value
Delete pos
Replace pos,value

where pos is the position of the string and pos should be between 1 and the current length of the string (in Insert command, pos can be 1 greater than the length), and value is a character. Actually many command lists can satisfy the request, but only one of them is required.
 

Sample Input
  
  
abcac bcd aaa aabaaaa
 

Sample Output
  
  
3 1 Delete 1 2 Replace 3,d 3 Delete 4 4 1 Insert 1,a 2 Insert 2,a 3 Insert 3,b 4 Insert 7,a

题目就一较为简单的动规,不想多说了,自己看代码,最好从中看出优化方程来,,,

#include<stdio.h>
#include<string.h>
#define SIZE 80
#define MAX 100000
int Min(int x,int y,int z){
    int min= x<y ? x : y;
    return min<z ? min : z;
}
int main(){
    char s1[SIZE];
    char s2[SIZE];
    int count[SIZE+1][SIZE+1];
    int flag[SIZE][SIZE];
    
    while(scanf("%s%s",s1,s2)!=EOF){
        //初始化flag[][] 
        for(int i=0;i<SIZE;++i)
            for(int j=0;j<SIZE;++j)
                flag[i][j]= s1[i]==s2[j] ? 0 : 1 ;
        //初始化count[][]    
        for(int i=0;i<=SIZE;++i)
            count[0][i]=count[i][0]=i;
        //计算count[][] 
        for(int i=1;i<=strlen(s1);++i)
            for(int j=1;j<=strlen(s2);++j)
                count[i][j]=Min(count[i-1][j]+1,count[i][j-1]+1,count[i-1][j-1]+flag[i-1][j-1]);
        printf("%d\n",count[strlen(s1)][strlen(s2)]);
        //打印方案 
        for(int is1=strlen(s1),is2=strlen(s2),k=1;k<=count[strlen(s1)][strlen(s2)];){
            
            int t;
            if(is1==0&&is2!=0) t=1;
            else if(is1!=0&&is2==0) t=3;
            else if(is1!=0&&is2!=0){
                if(count[is1][is2-1]==Min(count[is1-1][is2],count[is1-1][is2-1],count[is1][is2-1])) t=1;
                if(count[is1-1][is2]==Min(count[is1-1][is2],count[is1-1][is2-1],count[is1][is2-1])) t=3;
                if(count[is1-1][is2-1]==Min(count[is1-1][is2],count[is1-1][is2-1],count[is1][is2-1])) t= count[is1-1][is2-1]==count[is1][is2] ? 0:2;
            }
            switch(t){
                case 0 : --is1;--is2;break;//末尾元素一样 
                case 1 : printf("%d Insert %d,%c\n",k++,is1+1,s2[--is2]);break;//在s1末尾添加一个元素
                case 2 : printf("%d Replace %d,%c\n",k++,is1--,s2[--is2]);break;//替换末尾
                case 3 : printf("%d Delete %d\n",k++,is1--);break;//删除末尾元素 
            }
        } 
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值