poj 2780 Linearity

Linearity
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 6722 Accepted: 1499

Description

Alice often examines star maps where stars are represented by points in a plane and there is a Cartesian coordinate for each star. Let the Linearity of a star map be the maximum number of stars in a straight line.

For example, look at the star map shown on the figure above, the Linearity of this map is 3, because the star 1, star 2, and star 5 are within the same straight line, and there is no straight line that passes 4 stars.

You are to write a program to find the Linearity of a star map.

Input

Input will contain multiple test cases. Each describes a star map.

For each test case, the first line of the input contains the number of stars N (2 <= N <= 1000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0 <= X, Y <= 1000). There can be only one star at one point of the plane.

Output

Output the Linearity of the map in a single line.

Sample Input

5
0 0
2 0
0 2
1 1
2 2

Sample Output

3
#include<iostream>
#include<algorithm>
using namespace std;

double k[1002];
double x[1002],y[1002];

int main()
{
int n;
int i,j,p;
int cnt;
int num,max_num;
while(cin>>n)
{
for(i=0;i<n;i++)
{
cin>>x[i];
cin>>y[i];
}
num=2;
max_num=2;
for(i=0;i<n;i++)
{
cnt=0;
for(j=0;j<n;j++)
{
if(i==j)
continue;
if(x[i]==x[j])
k[cnt]=999999999;
else
{
k[cnt]=(y[i]-y[j])/(x[i]-x[j]);
}
cnt++;
}
sort(k,k+cnt);
num=2;
for(p=1;p<cnt;p++)
{
if(k[p]==k[p-1])
{
num++;
if(max_num<num)
max_num=num;
}
else
{
num=2;
if(max_num<num)
max_num=num;
}
}
}
cout<<max_num<<endl;
}
return 0;
}
 

转载于:https://www.cnblogs.com/w0w0/archive/2011/11/22/2258654.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值