Danganronpa

Problem Description
Chisa Yukizome works as a teacher in the school. She prepares many gifts, which consist of  n kinds with a[i] quantities of each kind, for her students and wants to hold a class meeting. Because of the busy work, she gives her gifts to the monitor, Chiaki Nanami. Due to the strange design of the school, the students' desks are in a row. Chiaki Nanami wants to arrange gifts like this:

1. Each table will be prepared for a mysterious gift and an ordinary gift.

2. In order to reflect the Chisa Yukizome's generosity, the kinds of the ordinary gift on the adjacent table must be different.

3. There are no limits for the mysterious gift.

4. The gift must be placed continuously.

She wants to know how many students can get gifts in accordance with her idea at most (Suppose the number of students are infinite). As the most important people of her, you are easy to solve it, aren't you?
 

 

Input
The first line of input contains an integer  T(T10) indicating the number of test cases.

Each case contains one integer n. The next line contains n (1n10) numbers: a1,a2,...,an(1ai100000).
 

 

Output
For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the answer of Chiaki Nanami's question.
 

 

Sample Input
1
2
3 2
 

 

Sample Output
Case #1: 2
 

 

Author
UESTC
 

 

Source

 一道水题,,写了半天没写出来。。。。。

#include <cstring>
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <stack>
#include <vector>
#include <queue>
#include <cmath>
using namespace std;
#define N 105000
typedef long long LL;
int a[N],b[N];
int len;
struct point
{
    int x,y;
} p[N];
int main()
{

    int t;
    char str[N];
    scanf("%d", &t);
    int n;
    int s = 1;
    while(t--)
    {
        scanf("%d",&n);

        int sum = 0;

        int Max = -1;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            sum += a[i];

        }

        if(sum == 1)
            printf("Case #%d: 1\n",s++);
        else
            printf("Case #%d: %d\n",s++,sum/2);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/biu-biu-biu-/p/5771802.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值