hdu 1238 Substrings (暴搜,枚举)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1238

Substrings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8391    Accepted Submission(s): 3862


Problem Description
You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.
 

Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.
 

Output
There should be one line per test case containing the length of the largest string found.
 

Sample Input
 
  
2 3 ABCD BCDFF BRCD 2 rose orchid
 

Sample Output
 
  
2 2

【题意】

在给定字符串中找到最长公共子串, 或者给定字符串子串的反串;

最多100字符串,最长100,直接枚举

求反串可以用 <algorithm>中的reverse函数 ;

【源代码】

#include <iostream>
#include <algorithm>
using namespace std;
string str[110]; 
int t;
int cmp(const string& a, const string& b){
	return a.length()<b.length();
}
int dfs(string now,string rev,int len){
	for(int i=1;i<t;i++){
		int sign=0;
		for(int j=0;j+len<=str[i].length();j++){
			string sub=str[i].substr(j,len); //返回从j 开始 长度为len的子串
			if(sub==now||sub==rev) 
			{
				sign=1;break; // 找到就继续找
			}
		}
		if(!sign)
			return 0; //否则直接退出
	}
	return len;
}
int main(){
	int n;
	cin>>n;

	while(n--){
		cin>>t;
		for(int i=0;i<t;i++)
			cin>>str[i];
		sort(str,str+t,cmp);
		int len=str[0].length();
		int max=0;
		for(int i=len;i>=1;i--){
			for(int j=0;j+i<=len;j++){
				string now=str[0].substr(j,i);
				string rev=now;
				reverse(rev.begin(),rev.end());
				//for(int k=now.length()-1;k>=0;k--) //原先手写的翻转字符串,用了上一行的reverse 速度从 140ms 下降到109ms
				//	rev+=now[k];
				//cout<<rev<<endl;
				int ma=dfs(now,rev,i);
				if(ma>max)
					max=ma;
			}
		}
		cout<<max<<endl;
	}
	return 0;
}


转载于:https://www.cnblogs.com/chaiwenjun000/p/5320995.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值