HDU -1238 Substrings(暴力枚举每个子串)

Substrings

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)

Problem Description
You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.

Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.

Output
There should be one line per test case containing the length of the largest string found.

Sample Input
2
3
ABCD
BCDFF
BRCD
2
rose
orchid

Sample Output
2
2

题意:n个串,找最长公共子串,子串的逆序也要是公共的。

直接找最短的那个串,比它长的一定不行,在每个长度内找其子串,然后看是否匹配,找不到就下一个子串,这个长度的字串用完了,就换另一个长度。

#include <stdio.h>
#include <string.h>

char a[105][105];

int main()
{
    int n;
    scanf("%d", &n);
    while(n--)
    {
        int t, i, minlen=105;
        char zheng[105], ni[105], s[105];
        scanf("%d", &t);
        for(i=0; i<t; i++)
        {
            scanf("%s", a[i]);
            if(strlen(a[i])<minlen)
            {
                minlen=strlen(a[i]);//找最短的
                strcpy(s, a[i]);
            }
        }

        int slen=minlen, flag;
        while(slen!=0)//遍历最短串的每个长度
        {
            for(int k=0; k<=minlen-slen; k++)//在slen长度内共有minlen-slen种组成子串的方式
            {
                flag=1;
                for(int j=0; j<slen; j++)//获得子串
                    ni[slen-1-j]=zheng[j]=s[j+k];
                ni[slen]=zheng[slen]='\0';//当心RE

                for(int j=0; j<t; j++)//检查是否匹配
                {
                    if(strstr(a[j], ni)==NULL&&strstr(a[j], zheng)==NULL)//没都找到
                    {
                        flag=0;
                        break;
                    }
                }
                if(flag==1)
                    break;
            }
            if(flag==1)
                    break;
            slen--;//这个长度的都不行,-1
        }
        printf("%d\n", slen);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值