HDU 1113 Word Amalgamation

Word Amalgamation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4429    Accepted Submission(s): 2229


Problem Description
In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.
 

 

Input
The input contains four parts:

1. a dictionary, which consists of at least one and at most 100 words, one per line;
2. a line containing XXXXXX, which signals the end of the dictionary;
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.
 

 

Output
For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.
 

 

Sample Input
tarp given score refund only trap work earn course pepper part XXXXXX resco nfudre aptr sett oresuc XXXXXX
 

 

Sample Output
score ****** refund ****** part tarp trap ****** NOT A VALID WORD ****** course ******
 

 

Source
 

 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1073  1200  1161  1043  1256 
 分析:既然要找字典中出现过的单词,那么我们可以把字典中出现的单词用map来进行记录。
下面的单词,比如对于单词a,我们先将它按字典序排序,再用next_permutation找出长度为len,并且字典序从小到大的单词变形,查找它是否在字典中出现过
(注意next_permutation并不会输出最开始的形态)
代码如下:
#include <iostream>
#include <string>
#include <queue>
#include <vector>
#include <cstring>
#include <map>
#include <algorithm>
using namespace std;
char a[10];
map<string,int>mp;
int len;
int main()
{
    int f,f2;
 //   freopen("1.out","w",stdout);
    f2=0;
   while(scanf("%s",a))
   {
      if(!strcmp(a,"XXXXXX"))
      {
         while(scanf("%s",a))
         {
              if(!strcmp(a,"XXXXXX")){
                    f2=1;
                break;
              }
             f=0;
           len=strlen(a);
           sort(a,a+len);
           if(mp[a]==1)
           {
               f=1;
            printf("%s\n",a);
           }
           while(next_permutation(a,a+len))
           {
               if(strlen(a)==len&&mp[a]==1){
                f=1;
               printf("%s\n",a);
               }
           }
           if(f==0)puts("NOT A VALID WORD");
           puts("******");
         }
      }
      else
      {
          mp[a]=1;
      }
      if(f2==1)break;
   }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/a249189046/p/7533111.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值