1041. Be Unique

Q: Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

A: 计数排序的应用。

#include<stdio.h>

int main()
{
    int n,i,bet;
    int count[10001]={0};
    int pos[10001]={0};
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d",&bet);
        count[bet]++;
        if(count[bet]==1)
            pos[bet] = i+1;
    }
    bet = -1;
    for(i=0;i<10001;i++)
    {
        if(count[i]==1&&(bet==-1||pos[i]<pos[bet]))
        {
            bet = i;
        }
    }
    if(bet==-1)
        printf("None\n");
    else
        printf("%d\n",bet);
    return 0;
}

  

转载于:https://www.cnblogs.com/summer-zhou/p/3176404.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值