问题 C: Be Unique (20)

问题 C: Be Unique (20)

时间限制: 1 Sec  内存限制: 32 MB
提交: 503  解决: 246
[提交][状态][讨论版][命题人:外部导入]

题目描述

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

输入

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

输出

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

样例输入

7 5 31 5 88 67 88 17
5 888 666 666 888 888

样例输出

31
None

主要的思想就是按输入的顺序来查询每个数字出现的次数

#include<cstdio>
#include<cstring>

const int maxn = 10010; 

int main(){
	int m;
	while(scanf("%d",&m)!=EOF){
		int hashTable[maxn]={0};
		int temp[m],i;
		for(i=0;i<m;i++){
			scanf("%d",&temp[i]);
			hashTable[temp[i]]++;
		}
		for(i=0;i<m;i++){     
			if(hashTable[temp[i]]==1){    //按输入顺序查询是否该号唯一 
				printf("%d\n",temp[i]);
				break;
			}
		}
		if(i==m){
			printf("None\n");
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值