ACM装箱问题

Description

Download as PDF
 

A set of n<tex2html_verbatim_mark> 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l<tex2html_verbatim_mark> and each item i<tex2html_verbatim_mark> has length li$ \le$l<tex2html_verbatim_mark> . We look for a minimal number of bins q<tex2html_verbatim_mark> such that

 

  • each bin contains at most 2 items,
  • each item is packed in one of the q<tex2html_verbatim_mark> bins,
  • the sum of the lengths of the items packed in a bin does not exceed l<tex2html_verbatim_mark> .

You are requested, given the integer values n<tex2html_verbatim_mark> , l<tex2html_verbatim_mark> , l1<tex2html_verbatim_mark> , ..., ln<tex2html_verbatim_mark> , to compute the optimal number of bins q<tex2html_verbatim_mark> .

 

Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

 

 


The first line of the input file contains the number of items n<tex2html_verbatim_mark>(1$ \le$n$ \le$105)<tex2html_verbatim_mark> . The second line contains one integer that corresponds to the bin length l$ \le$10000<tex2html_verbatim_mark> . We then have n<tex2html_verbatim_mark> lines containing one integer value that represents the length of the items.

 

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

 

 


For each input file, your program has to write the minimal number of bins required to pack all items.

 

Sample Input 

 

1

10
80
70
15
30
35
10
80
20
35
10
30

 

Sample Output 

 

6

解题思路:
这个题目的大意是,给定一些物块的长度和可以用来装物块的箱子的长度,要求一个箱子最多可以装两个物块,要求我们求出我们需要用到多少个箱子。我们先将箱子按从大到小的顺序排列,然后让一个目前最大的箱子和一个最小的箱子组合看是否可以装进箱子,如果不可以,那么我们就只装入大的那个箱子,否则将这两个箱子都装入。(我们可以用想x,y来分别控制从左往右和从右往左的下标)注意题目要求的空行,我就是一直挂在这个空行上。
程序代码:
#include <iostream>
#include <algorithm>
using namespace std;
int a[100005];
int fun(int a,int b)
{
    return a>b;
}
int main()
{
    int c;
    cin>>c;
    int g=1;
    while(c--)
    {
        if(g++!=1)
            cout<<endl;
        int n,l;
        cin>>n;
        cin>>l;
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
        }
        sort(a,a+n,fun);
        int x=0;
        int y=n-1;
        int s=0;
        while(x<y)
        {
            if(a[x]+a[y]<=l)
            {
                x++;
                y--;
                s++;
            }
            else
            {
                x++;
               s++;
            }
        }
         if(x==y)
            s++;
        cout<<s<<endl;
    }
    return 0;
}
 
  

 

 
  

 

 

 

转载于:https://www.cnblogs.com/xinxiangqing/p/4718433.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值