hdu 4856 Tunnels (记忆化搜索)

Tunnels

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 844    Accepted Submission(s): 249

Problem Description

Bob is travelling in Xi’an. He finds many secret tunnels beneath the city. In his eyes, the city is a grid. He can’t enter a grid with a barrier. In one minute, he can move into an adjacent grid with no barrier. Bob is full of curiosity and he wants to visit all of the secret tunnels beneath the city. To travel in a tunnel, he has to walk to the entrance of the tunnel and go out from the exit after a fabulous visit. He can choose where he starts and he will travel each of the tunnels once and only once. Now he wants to know, how long it will take him to visit all the tunnels (excluding the time when he is in the tunnels).

Input

The input contains mutiple testcases. Please process till EOF.
For each testcase, the first line contains two integers N (1 ≤ N ≤ 15), the side length of the square map and M (1 ≤ M ≤ 15), the number of tunnels.
The map of the city is given in the next N lines. Each line contains exactly N characters. Barrier is represented by “#” and empty grid is represented by “.”.
Then M lines follow. Each line consists of four integers x1, y1, x2, y2, indicating there is a tunnel with entrence in (x1, y1) and exit in (x2, y2). It’s guaranteed that (x1, y1) and (x2, y2) in the map are both empty grid.

Output

For each case, output a integer indicating the minimal time Bob will use in total to walk between tunnels.
If it is impossible for Bob to visit all the tunnels, output -1.

Sample Input

5 4 ....# ...#. ..... ..... ..... 2 3 1 4 1 2 3 5 2 3 3 1 5 4 2 1

Sample Output

7

 

记忆化搜索

view code#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <vector>
using namespace std;
typedef long long ll;
const int INF = 0x3f3f3f3f;
int dp[15][1<<15];
bool vis[15][1<<16];
int bit[25], n, m;
char str[20][20];
int dis[25][25], ans, tot;
int dx[4] = {0, 0, -1, 1};
int dy[4] = {-1, 1, 0, 0};

struct node
{
    int x, y, dis;
    node() {}
    node(int x, int y, int dis):x(x),y(y),dis(dis) {}
    bool operator == (const node &o){
        return x==o.x && y==o.y;
    }
};

struct edge
{
    node a, b;
}sto[20];


void init()
{
    for(int i=0; i<20; i++) bit[i] = 1<<i;
}

bool is_ok(int x, int y)
{
    if(x<0 || x>=n || y<0 || y>=n || str[x][y]=='#') return 0;
    return true;
}

bool look[20][20];
int getdis(node a, node b)
{
    queue<node >q;
    q.push(node(a.x, a.y, 0));
    memset(look, 0, sizeof(look));
    look[a.x][a.y]=1;
    while(!q.empty())
    {
        node o = q.front(); q.pop();
        if(o==b) return o.dis;
        for(int i=0; i<4; i++)
        {
            int x = o.x+dx[i], y = o.y+dy[i];
            if(!is_ok(x, y) || look[x][y]) continue;
            q.push(node(x, y, o.dis+1));
            look[x][y] = 1;
        }
    }
    return INF;
}

int dfs(int u, int s)
{
    if(vis[u][s]) return dp[u][s];
    if(s==tot) return 0;
    vis[u][s] = 1;
    int &res = dp[u][s];
    res = INF;
    for(int i=0; i<n; i++)
    {
        if(bit[i]&s || u==i) continue;
        res = min(dfs(i, s|bit[i])+dis[u][i], res);
    }
    return res;
}

void solve()
{
    for(int i=0; i<n; i++) scanf("%s", str[i]);
    for(int i=0; i<m; i++)
    {
        scanf("%d%d%d%d", &sto[i].a.x, &sto[i].a.y, &sto[i].b.x, &sto[i].b.y);
        sto[i].a.x --; sto[i].a.y--; sto[i].b.x--; sto[i].b.y--;
        for(int j=0; j<i; j++)
        {
            dis[i][j] = getdis(sto[i].b, sto[j].a);
            dis[j][i] = getdis(sto[j].b, sto[i].a);
        }
    }
    memset(vis, 0, sizeof(vis));
    int ans = INF;
    tot = bit[m]-1;
    for(int i=0; i<m; i++){
        int tmp = dfs(i, bit[i]);
        ans = min(tmp, ans);
    }
    if(ans==INF) ans = -1;
    printf("%d\n", ans);
}

int main()
{
//    freopen("in.txt", "r", stdin);
    init();
    while(scanf("%d%d", &n, &m)>0) solve();
    return 0;
}

转载于:https://www.cnblogs.com/zyx1314/p/3918569.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值