AtCoder - 4162 Independence

Problem Statement

 

In the State of Takahashi in AtCoderian Federation, there are N cities, numbered 1,2,…,NM bidirectional roads connect these cities. The i-th road connects City Ai and City Bi. Every road connects two distinct cities. Also, for any two cities, there is at most one road that directly connects them.

One day, it was decided that the State of Takahashi would be divided into two states, Taka and Hashi. After the division, each city in Takahashi would belong to either Taka or Hashi. It is acceptable for all the cities to belong Taka, or for all the cities to belong Hashi. Here, the following condition should be satisfied:

  • Any two cities in the same state, Taka or Hashi, are directly connected by a road.

Find the minimum possible number of roads whose endpoint cities belong to the same state. If it is impossible to divide the cities into Taka and Hashi so that the condition is satisfied, print -1.

Constraints

 

  • 2≤N≤700
  • 0≤MN(N−1)⁄2
  • 1≤AiN
  • 1≤BiN
  • AiBi
  • If ij, at least one of the following holds: AiAj and BiBj.
  • If ij, at least one of the following holds: AiBj and BiAj.

Input

 

Input is given from Standard Input in the following format:

N M
A1 B1
A2 B2
:
AM BM

Output

 

Print the answer.

Sample Input 1

 

5 5
1 2
1 3
3 4
3 5
4 5

Sample Output 1

 

4

For example, if the cities 1,2 belong to Taka and the cities 3,4,5 belong to Hashi, the condition is satisfied. Here, the number of roads whose endpoint cities belong to the same state, is 4.

Sample Input 2

 

5 1
1 2

Sample Output 2

 

-1

In this sample, the condition cannot be satisfied regardless of which cities belong to each state.

Sample Input 3

 

4 3
1 2
1 3
2 3

Sample Output 3

 

3

Sample Input 4

 

10 39
7 2
7 1
5 6
5 8
9 10
2 8
8 7
3 10
10 1
8 10
2 3
7 4
3 9
4 10
3 4
6 1
6 7
9 5
9 7
6 9
9 4
4 6
7 5
8 3
2 5
9 2
10 7
8 6
8 9
7 3
5 3
4 5
6 3
2 10
5 10
4 2
6 2
8 4
10 6

Sample Output 4

 

21


打ARC的时候都想到模型了。。。但就是没做出来mmp,还是水平差啊QWQ
主要没想到的地方是: 如果把补图二分图染色(不是二分图就无解),每个联通分量挑一类点出来弄到一起一定能凑成最后的一个团。
我也不知道为什么当时没想到QWQ,明明这么简单。。。。
然后直接背包完了更新答案就好了QWQ,怎么看都是一个NOIP题,药丸药丸

#include<bits/stdc++.h>
#define ll long long
using namespace std;
const int N=705;

inline int Get(int x){ return x*(x-1)>>1;}

int num[3],n,m,ans=1<<30,uu,vv,col[N],now;
bool f[N][N],g[N][N];

bool dfs(int x,int c){
	col[x]=c,num[c]++;
	
	for(int i=1;i<=n;i++) if(!g[x][i])
	    if(!col[i]){ if(!dfs(i,3-c)) return 0;}
	    else if(col[i]==c) return 0;
	
	return 1;
}

int main(){
	scanf("%d%d",&n,&m);
	for(int i=1;i<=m;i++)
	    scanf("%d%d",&uu,&vv),g[uu][vv]=g[vv][uu]=1;
	
	f[0][0]=1;
	for(int i=1;i<=n;i++) g[i][i]=1;
	
	for(int i=1;i<=n;i++) if(!col[i]){
		num[1]=num[2]=0;
		if(!dfs(i,1)){ puts("-1"); return 0;}
		
		now++;
		for(int j=0;j<=n;j++) if(f[now-1][j]) f[now][j+num[1]]=f[now][j+num[2]]=1;
	}
	
	for(int i=0;i<=n;i++) if(f[now][i]) ans=min(ans,Get(i)+Get(n-i));
	
	printf("%d\n",ans);
	return 0;
}
 
 

  

 

转载于:https://www.cnblogs.com/JYYHH/p/9231206.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值