sdut oj--1489 求二叉树的先序遍历

求二叉树的先序遍历

 
Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

 已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历

输入

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。 

输出

 输出二叉树的先序遍历序列

示例输入

2
dbgeafc
dgebfca
lnixu
linux

示例输出

abdegcf
xnliu

提示

 

来源

 GYX

示例程序

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

typedef struct node
{
    char ch;
    struct node *lch,*rch;
}*A,M;
A creat(A t,char mid[],char last[],int n)
{
    if(n<=0)
        return NULL;
    t=(A)malloc(sizeof(M));
    t->ch=last[n-1];
    int k=strchr(mid,last[n-1])-mid;
    t->lch=creat(t->lch,mid,last,k);
    t->rch=creat(t->rch,mid+k+1,last+k,n-k-1);
    return(t);
}

void pre(A f)
{
    if(f==NULL)
        return ;
    printf("%c",f->ch);
    pre(f->lch);
    pre(f->rch);

}

int main()
{
    A f;
    int n,len;
    char last[55],mid[55];
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        scanf("%s%s",mid,last);
        len=strlen(mid);
        f=creat( f,mid,last,len);
        pre(f);
        printf("\n");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/Misty5/articles/4099538.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值