二叉树学习-已知中序、后序,求先序


  
  

Description

 已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历

Input

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。 

Output

 输出二叉树的先序遍历序列

Sample Input

2
dbgeafc
dgebfca
lnixu
linux

Sample Output

abdegcf
xnliu
代码如下:
#include <iostream>
#include"cstdio"
#include"cstring"
#include"cstdlib"
using namespace std;
char ins[1050],pos[1050];
struct node
{
    char data;
    node *lch,*rch;
};
node *build(char *ins ,char*pos,int n)
{
    if(n<=0) return NULL;
    node *p;
    p=(node*)malloc(sizeof(node));
    p->data=pos[n-1];
    int k;
    for( k=0;k<n;k++)
        if(ins[k]==pos[n-1])
        break;
    p->lch=build(ins,pos,k);
    p->rch=build(ins+k+1,pos+k,n-k-1);
    return p;
}
void xianxu(node *p)
{
    if(p!=NULL)
    {
        printf("%c",p->data);
        xianxu(p->lch);
        xianxu(p->rch);
    }
}
int main()
{
     int t;
     scanf("%d",&t);
     while(t--)
     {memset(ins,'\0',sizeof(ins));
      memset(pos,'\0',sizeof(pos));
      scanf("%s%*c%s",ins,pos);
      node *tree;
      tree=(node*)malloc(sizeof(node));
      int n=strlen(ins);
      tree=build(ins,pos,n);
      xianxu(tree);
      putchar('\n');
     }
    return 0;
}
  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值