SDUT-1489-求二叉树的先序遍历

SDUT-1489-求二叉树的先序遍历

Problem Description

已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历

Input

输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。

Output

输出二叉树的先序遍历序列

Sample Input

2
dbgeafc
dgebfca
lnixu
linux

Sample Output

abdegcf
xnliu

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
//后序遍历的最后一个为根节点,就是b[n-1],再在中序遍历中找到根节点的位置
struct treenode
{
    char data;
    struct treenode *l;
    struct treenode *r;
};
struct treenode *creat(int n, char a[100000], char b[100000])
{
    struct treenode *root;
    if(n == 0)
        return NULL;
    else
    {
        root = (struct treenode *)malloc(sizeof(struct treenode));
        root -> data = b[n - 1];
        int i;
        for(i = 0;i < n;i++)
        {
            if(a[i] == b[n - 1])
                break;//找根节点的位置
        }
        root -> l = creat(i, a, b);
        root -> r = creat(n - i - 1, a + i + 1, b + i);
    }
    return root;
};
void preorder(struct treenode *root)
{
    if(root)
    {
        printf("%c", root -> data);
        preorder(root -> l);
        preorder(root -> r);
    }
}
int main()
{
    char a[100000], b[100000];
    struct treenode *root;
    int t;
    scanf("%d", &t);
    getchar();
    while(t--)
    {
        scanf("%s", a);
        scanf("%s", b);
        int n = strlen(a);
        root = creat(n, a, b);
        preorder(root);
        printf("\n");
    }
    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值