The Cow Lexicon(POJ-3267)

Problem Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L 
Line 2: L characters (followed by a newline, of course): the received message 
Lines 3..W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.
 

Sample Input

6 10

browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

题意:给出一个长度为l的字符串,与w个词,问最少删掉字符串中的几个字母后可使字符串全部由所给的单词组成。

思路:

用 f[i]=n 来表示字符串删掉n个字母后剩下的串可由单词构成,易得:

若不存在单词可以与字符串str中str[i]开头的字符串匹配,则有:f[i]=f[i+1]+1

若存在单词可以匹配,且str[t-1]为可以匹配的字符串的最后一个字符,匹配的单词的长度为n,则有:f[i]=min(f[i+1]+1,f[t]+t-i-n)

Source Program

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstdlib>
#include<queue>
#include<set>
#include<vector>
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define N 1001
#define MOD 123
#define E 1e-6
using namespace std;
string str;
string word[N];
int f[N];
int main()
{


    int w,l;
    scanf("%d%d",&w,&l);
        cin>>str;
    for(int i=0;i<w;i++)
        cin>>word[i];

    f[l]=0;
    for(int i=l-1;i>=0;i--)
    {
        f[i]=f[i+1]+1;
        for(int j=0;j<w;j++)
        {
            if(word[j].length()<=l-i && word[j].at(0)==str[i])//当第j个单词的首字母与字符串中匹配时
            {
                int t=i;
                int n=0;
                while(t<l)
                {
                    if(word[j].at(n)==str[t++])//匹配单词第n个字母是否与字符串匹配
                        n++;
                    if(n==word[j].length())
                    {
                        f[i]=min(f[t]+t-i-n,f[i]);
                        break;
                    }
                }
            }
        }
    }
    printf("%d\n",f[0]);
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值