poj3311Hie with the Pie

Hie with the Pie
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7599 Accepted: 4088

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

Source

题意:求从点0出发经过其他所有点再回到0的最短路径

分析:很经典的状压dp问题,不过我当时状态想错了,以为用一维就可以表示,这样导致的后果就是可以直接从一个点跳到另一个毫不相干的点上去,事实上,我们需要用二维表示状态,设dp[s][i]表示状态s的情况下最终走到i的最短距离,s是一串二进制串,每一位表示是否经过第i个点,状态转移方程很容易看出来,我们可以这样分析:另取一个已经经过的点j,如果我们要达到i,我们可以用没经过i的状态但已经走到j的状态,加上i到j的距离更新,具体看代码:

#include <cstring>
#include <cstdio>
#include <iostream>
#include <algorithm>

using namespace std;

int n, d[15][15], dp[1 << 12][12], ans;

int main()
{
    while (scanf("%d", &n) && n != 0)
    {
        for (int i = 0; i <= n; i++)
            for (int j = 0; j <= n; j++)
                scanf("%d", &d[i][j]);
        for (int k = 0; k <= n; k++)
            for (int i = 0; i <= n; i++)
                for (int j = 0; j <= n; j++)
                    if (d[i][k] + d[k][j] < d[i][j])
                        d[i][j] = d[i][k] + d[k][j];
        for (int s = 0; s <= (1 << n) - 1; s++)
        {
            for (int i = 1; i <= n; i++)
            {
                if (s & (1 << (i - 1)))
                {
                    if (s == (1 << (i - 1)))
                        dp[s][i] = d[0][i];
                    else
                    {
                        dp[s][i] = 1000000000;
                        for (int j = 1; j <= n; j++)
                            if ((s & (1 << (j - 1))) && i != j)
                                dp[s][i] = min(dp[s][i], dp[s ^ (1 << (i - 1))][j] + d[j][i]);
                    }
                }
            }
        }
        ans = 1000000000;
        for (int i = 1; i <= n; ++i)
            ans = min(dp[(1 << n) - 1][i] + d[i][0], ans);
        printf("%d\n", ans);
    }

    return 0;
}

 

转载于:https://www.cnblogs.com/zbtrs/p/7091580.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值