poj3311Hie with the Pie【状压dp 类TSP】

8 篇文章 0 订阅
2 篇文章 0 订阅


Hie with the Pie
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5565 Accepted: 3001

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

题意:类TSP问题每个点可以多次经过

#include<cstdio>
#include<cstdlib>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
int map[15][15];
int dp[1<<15][15];//状态为i的时候到达j的最短花费; 
int MIN(int a,int b){
	return a<b?a:b;
}
int main()
{
	int n,i,j,k;
	while(scanf("%d",&n),n){
		memset(dp,0,sizeof(dp));
		memset(map,0x3f,sizeof(map));
		for(i=0;i<=n;++i){
			for(j=0;j<=n;++j)
				scanf("%d",&map[i][j]);
		}
//		计算任意两点间最短距离; 
		for(k=0;k<=n;++k){
			for(i=0;i<=n;++i){
				for(j=0;j<=n;++j){
					map[i][j]=MIN(map[i][j],map[i][k]+map[k][j]);
				}
			}
		}
		for(int state=0;state<(1<<n);++state){//枚举所有状态; 
			for(i=1;i<=n;++i){
				if(state&(1<<(i-1))){
					if(state==(1<<(i-1)))dp[state][i]=map[0][i];//如果直接由起点到i; 
					else {//中间经过其它点; 
						dp[state][i]=inf;
						for(j=1;j<=n;++j){
							if((state&(1<<(j-1)))&&j!=i){
								dp[state][i]=MIN(dp[state][i],dp[state^(1<<(i-1))][j]+map[j][i]);//state^(1<<(i-1))右数第i为数取反即可以理解为到达i之前先到的地方; 
							}
						}
					}
				}
			}
		}
		int ans=dp[(1<<n)-1][1]+map[1][0];
		for(i=2;i<=n;++i){
			ans=MIN(ans,dp[(1<<n)-1][i]+map[i][0]);
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值