poj3311 Hie with the Pie

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

题意:给你n+1个点以及任意两个点之前的距离(不经过其他点),你现在在0这个点,让你走最短的路程走完n个点并回到0这个点,不同的点可以重复走。

思路:因为点可以走任意多次,所以我们先初始化出任意两个点之间的最短距离,因为范围小,用floyd就行了。然后我们用dp[state][i]表示当前走完点的状态为state,当前正在i这个点所要走的最短距离。状态转移方程为dp[state][i]=min(dp[state][i],dp[state1][j]+dist[j][i] );写的时候有两种写法,一种是使得state为已经求出的状态,推state|(1<<(j-1)),还有一种是state为待求状态,state由state1=state^(1<<(j-1))得到。


写法一:顺推

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
typedef long long ll;
typedef long double ldb;
#define inf 99999999
#define pi acos(-1.0)
#define maxn 15
int dist[maxn][maxn],dp[1<<maxn][maxn];

int main()
{
    int n,m,i,j,T,state,k,state1;
    while(scanf("%d",&n)!=EOF && n!=0)
    {
        for(i=0;i<=n;i++){
            for(j=0;j<=n;j++){
                scanf("%d",&dist[i][j]);
            }
        }
        for(k=0;k<=n;k++){
            for(i=0;i<=n;i++){
                for(j=0;j<=n;j++){
                    if(dist[i][j]>dist[i][k]+dist[k][j]){
                        dist[i][j]=dist[i][k]+dist[k][j];
                    }
                }
            }
        }

        for(i=0;i<=n;i++){
            for(state=0;state<(1<<n );state++){
                dp[state][i]=inf;
            }
        }
        dp[0][0]=0;
        for(state=1;state<(1<<n);state++){
            for(i=1;i<=n;i++){
                if(state&(1<<(i-1))){
                    if(state==(1<<(i-1))){
                        dp[state][i]=min(dp[state][i],dist[0][i] );
                    }
                    else{
                        state1=state^(1<<(i-1));
                        for(j=1;j<=n;j++){
                            if(state1&(1<<(j-1))){
                                dp[state][i]=min(dp[state][i],dp[state1][j]+dist[j][i] );
                            }

                        }
                    }
                }
            }
        }
        int ans=inf;
        for(i=1;i<=n;i++){
            ans=min(ans,dp[(1<<n )-1][i]+dist[i][0]);
        }
        printf("%d\n",ans);
    }
    return 0;
}

写法二:逆推

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
typedef long long ll;
typedef long double ldb;
#define inf 99999999
#define pi acos(-1.0)
#define maxn 15
int dist[maxn][maxn],dp[1<<maxn][maxn];

int main()
{
    int n,m,i,j,T,state,k,state1;
    while(scanf("%d",&n)!=EOF && n!=0)
    {
        for(i=0;i<=n;i++){
            for(j=0;j<=n;j++){
                scanf("%d",&dist[i][j]);
            }
        }
        for(k=0;k<=n;k++){
            for(i=0;i<=n;i++){
                for(j=0;j<=n;j++){
                    if(dist[i][j]>dist[i][k]+dist[k][j]){
                        dist[i][j]=dist[i][k]+dist[k][j];
                    }
                }
            }
        }

        for(i=0;i<=n;i++){
            for(state=0;state<(1<<n );state++){
                dp[state][i]=inf;
            }
        }
        dp[0][0]=0;
        for(i=1;i<=n;i++){
            dp[1<<(i-1)][i]=dist[0][i];
        }
        for(state=1;state<(1<<n)-1;state++){
            for(i=1;i<=n;i++){
                if(state&(1<<(i-1))){
                    for(j=1;j<=n;j++){
                        if( (state&(1<<(j-1)))==0 ){
                            dp[state|(1<<(j-1))][j]=min(dp[state|(1<<(j-1))][j],dp[state][i]+dist[i][j] );
                        }

                    }
                }
            }
        }
        int ans=inf;
        for(i=1;i<=n;i++){
            ans=min(ans,dp[(1<<n )-1][i]+dist[i][0]);
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值