Spoj LCS2 - Longest Common Substring II

题目描述

A string is finite sequence of characters over a non-empty finite set Σ.

In this problem, Σ is the set of lowercase letters.

Substring, also called factor, is a consecutive sequence of characters occurrences at least once in a string.

Now your task is a bit harder, for some given strings, find the length of the longest common substring of them.

Here common substring means a substring of two or more strings.

输入输出格式

输入格式:

 

The input contains at most 10 lines, each line consists of no more than 100000 lowercase letters, representing a string.

 

输出格式:

 

The length of the longest common substring. If such string doesn't exist, print "0" instead.

 

输入输出样例

输入样例#1: 
alsdfkjfjkdsal
fdjskalajfkdsla
aaaajfaaaa
输出样例#1: 
2



大概就是要你求最多10个串的最长公共子串,裸上后缀自动机。。。。

#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#define ll long long
#define maxn 4000005
using namespace std;
int a[maxn],c[maxn],tot;
int base=1,cnt=1,pre=1,n;
int f[maxn],ch[maxn][26];
int l[maxn],siz[maxn],ans=0;
char s[maxn];

inline void ins(int x){
	int p=pre,np=++cnt;
	pre=np,l[np]=l[p]+1;
	siz[np]=base;
	
	for(;p&&!ch[p][x];p=f[p]) ch[p][x]=np;
	if(!p) f[np]=1;
	else{
		int q=ch[p][x];
		if(l[q]==l[p]+1) f[np]=q;
		else{
			int nq=++cnt;
			l[nq]=l[p]+1;
			memcpy(ch[nq],ch[q],sizeof(ch[q]));
			f[nq]=f[q];
			f[q]=f[np]=nq;
			for(;ch[p][x]==q;p=f[p]) ch[p][x]=nq;
		}
	}
}

inline void build(){
	n=strlen(s),tot+=n;
	for(int i=0;i<n;i++) ins(s[i]-'a');
}

inline void solve(){
	base--;
	for(int i=1;i<=cnt;i++) c[l[i]]++;
	for(int i=tot;i>=0;i--) c[i]+=c[i+1];
	for(int i=1;i<=cnt;i++) a[c[l[i]]--]=i;
	
	for(int i=1;i<=cnt;i++){
		int now=a[i];
		siz[f[now]]|=siz[now];
		if(siz[now]==base) ans=max(ans,l[now]);
	}
}

int main(){
	while(scanf("%s",s)==1) build(),base<<=1;
	solve();
	printf("%d\n",ans);
	return 0;
}

  

 

转载于:https://www.cnblogs.com/JYYHH/p/8458206.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值