Oil Deposits-hdu1241-bfs+dfs

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
Sample Output
0
1
2
2
题意:统计给定的图中有多少油田数,其中,'@'表示油田,如果两个油田水平、垂直或对角方向上相邻的话,视为一个油田。
广度优先搜索:遍历mp[m][n]数组,如果发现mp[i][j]='@',油田数加1,同时使用bfs(),将i,j存入队列queue中,并且将mp[i][j]周围的'@'置为'*',避免后续重复统计。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
char mp[110][110];
typedef pair<int,int>P;
int dir[8][2]={{-1,0},{0,-1},{1,-1},{-1,1},{1,0},{0,1},{1,1},{-1,-1}};
int m,n;
queue<P>q;
void bfs(int x,int y)
{
    mp[x][y]='*';
    q.push(P(x,y));
    while(!q.empty()){
        P tmp=q.front();
        q.pop();
        for(int i=0;i<8;i++){
            int xx=tmp.first+dir[i][0],yy=tmp.second+dir[i][1];
            if(xx>=0&&xx<m&&yy>=0&&yy<n&&mp[xx][yy]=='@'){
                mp[xx][yy]='*';
                q.push(P(xx,yy));
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d",&m,&n)){
        if(m==0)
            break;
        for(int i=0;i<m;i++){
            scanf("%s",mp[i]);
        }
        int ans=0;
        for(int i=0;i<m;i++){
            for(int j=0;j<n;j++){
                if(mp[i][j]=='@'){
                    bfs(i,j);
                    ans++;
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
深度优先搜索:遍历mp[m][n]数组,如果发现mp[i][j]='@',油田数加1,同时使用dfs()将mp[i][j]周围的'@'置为'*',避免后续重复统计。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
char mp[110][110];
int dir[8][2]={{-1,0},{0,-1},{1,-1},{-1,1},{1,0},{0,1},{1,1},{-1,-1}};int m,n;

void dfs(int x,int y)
{
    mp[x][y]='*';for(int i=0;i<8;i++){
        int xx=x+dir[i][0],yy=y+dir[i][1];
        if(xx>=0&&xx<m&&yy>=0&&yy<n&&mp[xx][yy]=='@'){
            dfs(xx,yy);
        }
    }
}
int main()
{
    while(~scanf("%d%d",&m,&n)){
        if(m==0)
            break;
        for(int i=0;i<m;i++){
            scanf("%s",mp[i]);
        }
        int ans=0;for(int i=0;i<m;i++){//统计油田数的关键步骤
            for(int j=0;j<n;j++){
                if(mp[i][j]=='@'){
                    dfs(i,j);
                    ans++;
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
 

转载于:https://www.cnblogs.com/LJHAHA/p/11206191.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值