Oil Deposits- HDu1241 (DFS)

                                                           Oil Deposits

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 


Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.


Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0
1
2
2

这是一道典型的dfs题,对于一个点,如果这个点是@的话,dfs上下左右等八个方向,如果遇到@的话,就变成*。然后遍历每一个点。

该题还可以bfs的方法,说实话,现在还不会   -_-!!


#include<iostream> 
#include<cstdio>
#include<algorithm>
using namespace std;
int xy[8][2]={1,0,1,-1,1,1,0,1,0,-1,-1,0,-1,1,-1,-1};         //八个方向。
char s[105][105];
int ans ,m,n;
void dfs(int x,int y){
	s[x][y] = '*';             // 将@变为*
	for(int i = 0;i < 8; i++){
		int a = x + xy[i][0];
		int b = y + xy[i][1];
		if(a < m && a >= 0 && b < n && b >= 0 && s[a][b] == '@')
				dfs(a,b);
	}
	return;                        
}
int main(){
	while(cin >> m >> n && n && m){
		ans = 0;
		for(int  i = 0;i < m; i++)
			scanf("%s",s[i]);
		for(int i = 0; i < m;i++)
			for(int j = 0; j < n;j++){            //遍历每个点
				if(s[i][j] == '@'){              //判断该点是不是@,如果是的话,dfs。
					dfs(i,j);
					ans++;
				}
			} 
		cout << ans<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值