【贪心算法】POJ-1328 区间问题

一、题目

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

二、思路&心得

  • 贪心算法与区间问题:以每个岛屿的坐标为中心,d为半径构造圆,该圆与X轴的两个交点即构成一个区间,若在这个区间上的任何雷达均可扫描到该岛屿。通过对n个岛屿进行处理,可得到n个区间,则问题转化成区间问题。
  • 每个区间a[i]有两个端点:first和second,对区间数组a按second进行升序排序,然后从左向右扫描,对于每一个区间a[i],若a[i].first小于之前选择的second的值,则不做任何处理,知道找到大于second的区间,然后进行下一个循环。
  • 在数据输入的时候可进行特判,如若有岛屿的Y坐标大于d或则Y坐标<0或则d<0,则输入完成后直接返回-1即可。
  • 数据定义记得用浮点型进行定义。
  • PS:在做贪心问题时,务必确定所做的贪心选择的正确性,在做这题时因为一开始的方向就是错误的,导致浪费了很多时间。

三、代码

#include<cstdio>
#include<cmath>
#include<algorithm>
#define MAX_SIZE 1005
using namespace std;

typedef pair<double, double> P;

P a[MAX_SIZE];

int n, ans;

double x, y, d;

bool cmp(P a, P b) {
    if (a.second < b.second) return true;
    else return false;
}

int solve() {
    bool flag = true;
    double end;
    ans = 0;
    for (int i = 0; i < n; i ++) {
        scanf("%lf %lf", &x, &y);
        if (y > d || y < 0) flag = false;
        if (flag) {
            a[i].first = x - sqrt(d * d - y * y);
            a[i].second = x + sqrt(d * d - y * y);
        }
    }
    if (!flag || d < 0) return -1;
    sort(a, a + n, cmp);
    for (int i = 0; i < n; i ++) {
        if (flag) {
            end = a[i].second;
            ans ++;
            flag = false;
            continue;       
        }
        if (a[i].first > end) {
            flag = true;
            i --;
         }
    }
    return ans;
}

int main() {
    int step = 1;
    while (~scanf("%d %lf", &n, &d)) {
        if (!n && !d) break;
        printf("Case %d: %d\n", step ++, solve());
        getchar();
    }
    return 0;
}

转载于:https://www.cnblogs.com/CSLaker/p/7285114.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值