POJ Radar Installation 1328(雷达)贪心算法

问题描述

问题链接

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

算法分析

贪心算法,对于每个小岛,在坐标轴上求出可以覆盖小岛的雷达的坐标范围。对所有的范围区域进行区间右端递增顺序排列,当右端坐标相同时,左端大的区间排在前面;当右端坐标不同时,按左端坐标进行递增排列,左端坐标小的排在前面。对于每个范围区域,选择右端点设置雷达,按上述规则排列好顺序的区域,当前面的区域的右端点小于后面区域的左端点时,增设新的雷达,雷达设置在后面区域的右端点。对所有的雷达分布区间排序,if (a.r == b.r) return a.l > b.l;else return a.r < b.r; 对于最少雷达数量的计算,if(a[i].right<a[j].left) number++。

代码

#include<iostream>
#include<algorithm>
using namespace std;

struct Range
{
	double l;
	double r;
}range[1000];

bool cmp(Range a, Range b)
{
	if (a.r == b.r) 
		return a.l > b.l;
	return a.r < b.r;
}

int main()
{
	int n, d, counter = 0, end1,end2;
	double x, y;
	while (1) 
	{
		cin >> n >> d;
		if (!n)
			break;
		bool flag =true;
		for (int i = 0; i < n; ++i) 
		{
			cin >> x >> y;
			flag = flag && y <= d;
			if (flag) 
			{
				range[i].l = x - sqrt(d * d - y * y);
				range[i].r = x + sqrt(d * d - y * y);
			}
		}
		sort(range, range + n, cmp);
		int num = -1;
		if (flag) 
		{
			num = 1;
			double maxr = range[0].r; 
			for (int i = 1; i < n; ++i) 
			{
				if (range[i].l > maxr) 
				{ 
					maxr = range[i].r;
					++num;
				}
			}
		}
		cin >> end1 >> end2;
		if(end1==0&&end2==0)
		cout << "Case" << ++counter << ":" <<num << endl;
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值