solution of POJ: 1328.Radar Installation

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
这里写图片描述

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1


结题思路
题意要求我们找到能够扫描到全部海岛的最少的灯塔数。
要求1:当能扫描到两个海岛的圆心区域出现交集时,我们可以通过一个灯塔就扫描到这两个海岛;
要点2:当某个海岛需要跟前一个海岛共用灯塔时,这个海岛必须跟前面的合法的交集区出现交集。

引用块内容

当我们首先读入一个海岛,得到这个海岛的灯塔圆心区域的右值A;读入第二个海岛,此时,C < A && B < A;这时,如果我们要读入第三个海岛,而这个海岛要跟前面的海岛共用灯塔,需要第三个海岛跟BC出现交集

程序步骤
第一步、读入数据,首先对不合法的样例直接输出非法。
第二步、对合法样例的灯塔圆心区域的左值进行递增排序。
第三步、根据区域交集的情况,判断需要的灯塔个数。

具体程序(AC)如下

#include <iostream>
#include <algorithm>
#include <set>
#include <vector>
#include <cmath>
#include <limits>
using namespace std;
struct node
{
    double start;
    double end;
    // const成员函数不可以修改对象的数据,不管对象是否具有const性质.它在编译时,以是否修改成员数据为依据,进行检查
    bool operator < (const node& b) const
    {
        return start < b.start;
    }
};
int main()
{
    int n, d;
    int x, y;
    int result = 0;
    double distance;
    int index = 0;
    while(cin>> n >>d)
    {
        index++;
        result = 0;
        if(n == 0 && d == 0)
            break;
        vector<node> island(n);
        for(int i = 0; i < n; ++i)
        {
            cin>> x >> y;
            if(result < 0)//即使出现了非法数据,我们还是需要把样例全部读一遍
                continue;
            if(y > d)//海岛位置超过了灯塔的扫描半径
            {   
                result = -1;
                continue;
            }
            else
            {
                distance = sqrt(d * d - y * y + 0.0);
                island[i].start = x - distance;//灯塔圆心的左值
                island[i].end = x + distance;//灯塔圆心的右值
            }
        }
        if(result < 0)
            cout<<"Case "<<index<<": "<< -1<<endl;
        else
        {
            sort(island.begin(), island.end());
            double end = -numeric_limits<double>::max();
            int counter = 0;
            for(int i = 0; i < n; ++i)
            {
                if(island[i].start > end)//需要一个新灯塔
                {
                    counter++;
                    end = island[i].end;
                }
                else if(island[i].end < end)//出现交集,且为内包含
                    end = island[i].end;
            }
            cout<<"Case "<<index<<": "<<counter<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值