HDU1061 - Rightmost Digit

Given a positive integer N, you should output the most right digit of N^N. 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case contains a single positive integer N(1<=N<=1,000,000,000). 

Output

For each test case, you should output the rightmost digit of N^N. 

Sample Input

2
3
4

Sample Output

7
6

思路:这题是真正的水题,直接套用模板QAQ

#include<bits/stdc++.h>
using namespace std;
long long PowerMod(long long a, long long b, long long c)
{
    long long ans = 1;
    a = a % c; //对刚进来的a进行取模运算,避免后面第一次求平方运算溢出
    while(b)
    {
        if(b&1) //相当于b % 2 = = 1对二进制下的 b 进行按位与1运算,求二进制下 b 的最低位是否为1
            ans = ans * a % c; //对结果进行保存
        b>>=1; //相当于b = b/2;二进制下的 b 右移一位,相当于十进制下的 b 除以2
        a = a * a % c;
    }
    return ans;
}

int main()
{
    long long t,n,m;
    cin>>t;
    while(t--)
    {
        cin>>n;
        m=PowerMod(n,n,10);
        cout<<m<<endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/aerer/p/9931036.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值