hdu1061(快速幂求模)

Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2
3
4
Sample Output
7
6

Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

问题简介:输入一个数n,求出n^n的个位数是什么;
问题分析:其实就是快速幂求模,模为10;
程序分析:ab=(a2)(b/2);

#include <iostream>
using namespace std;

int ksm(int a, int x,int m)
{
	int ans=1;
	while (x)
	{
		a = a % m;
		if (x & 1)ans = (ans*a) % m;//奇数乘多一次
		a =(a*a)%m; x /= 2;			//每次乘完都取模,减小计算量
	}
	return ans;
}
int main()
{
	int n,t; 
	cin >> t;
	while (t--) 
	{
		cin >> n;
		cout << ksm(n, n, 10) << endl;
	}

}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值