PTA 09-排序3 Insertion or Heap Sort (25分)

题目地址

https://pta.patest.cn/pta/test/16/exam/4/question/676

 

5-14 Insertion or Heap Sort   (25分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer NN (\le 100100). Then in the next line, NN integers are given as the initial sequence. The last line contains the partially sorted sequence of the NN numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9


/*
评测结果
时间	结果	得分	题目	编译器	用时(ms)	内存(MB)	用户
2017-07-06 18:04	答案正确	25	5-14	gcc	14	1	
测试点结果
测试点	结果	得分/满分	用时(ms)	内存(MB)
测试点1	答案正确	7/7	1	1
测试点2	答案正确	6/6	2	1
测试点3	答案正确	2/2	1	1
测试点4	答案正确	2/2	2	1
测试点5	答案正确	4/4	14	1
测试点6	答案正确	4/4	14	1
*/
#include<stdio.h>
#define MAXN 100
int A[MAXN],B[MAXN],tmp[MAXN];
int gNextTurnToPrint=0;
int gPrinted=0;
int gSortType=0;
void swap(int *a,int *b)
{
	int temp;
	temp=*a;
	*a=*b;
	*b=temp;
}
void DBG_printarray(int N) //调试用函数
{
	int d;
	for(d=0;d<N;d++)
	{
		printf("%d ",A[d]);
	}
		printf("\n");
}
void CheckMethod(int N)
{
	if(gPrinted)
		return;
		
	int i;
	if (gNextTurnToPrint==1)
	{
		if(gSortType==0)
			printf("Insertion Sort\n");
		else
			printf("Heap Sort\n");
			
		for(i=0;i<N;i++)
			{
				printf("%d",A[i]);
				if(i!=N-1)
					printf(" ");
			}
		gNextTurnToPrint=0;
		gPrinted=1;
		return;
	}
	
	for (i=0;i<N;i++)
	{
		if(A[i]!=B[i])
		return;
	}
	gNextTurnToPrint=1;
}

void InsertionSort(int a[],int left ,int right,int N)
{
	int i,j,temp;
	for(i=left;i<right;i++)
	{
		temp=a[i+1];
		for(j=i+1;j>left;j--)
		{
			if(temp<a[j-1])
				a[j]=a[j-1];
			else break;
		}
		a[j]=temp;
		CheckMethod(N);
	}
}

void PrecDown(int a[],int x,int N)
{
	int temp=a[x];
	int parent,child;
	parent=x;
	for(child=2*parent+1; child<= N ;child=child*2+1)
	{
		if(child!=N)
		{
			if(a[child+1]>a[child])
				child++;
		}
		if(temp<a[child])
		{
   			a[parent]=a[child];
			parent=child;
		}

		else break;
	}
	a[parent]=temp;
//	DBG_printarray(N+1);
}

void HeapSort(int a[],int N)
{
	//建大顶堆然后把首元素后移
	int i,ptrRight=N-1,temp,d;
	for(i=(ptrRight-1)/2;i>=0;i--)
	{
		PrecDown(a,i,ptrRight);
	}
	for(i=ptrRight;i>0;i--)
	{
		temp=a[i];
		a[i]=a[0];
		a[0]=temp;
		PrecDown(a,0,i-1);
		CheckMethod(N);

	}
}


int main()
{
	int i,N;
	scanf("%d",&N);
	
	for(i=0;i<N;i++)
	{
		scanf("%d",&A[i]);
		tmp[i]=A[i];
	}

	for(i=0;i<N;i++)
	{
		scanf("%d",&B[i]);
	}
	
	InsertionSort(A,0,N-1,N);
	
	if(!gPrinted)
	{
		for(i=0;i<N;i++)
		{
			A[i]=tmp[i];
		}
		gSortType=1;
		HeapSort(A,N);
	}

}

  

转载于:https://www.cnblogs.com/gk2017/p/7141134.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值