09-排序3 Insertion or Heap Sort   (25分)

9 篇文章 0 订阅

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer NNN (≤100\le 100100). Then in the next line, NNN integers are given as the initial sequence. The last line contains the partially sorted sequence of the NNN numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9


解析:每做一次迭代,都判别一下有是否与第二个序列相同,相同就再做一次迭代,然后退出。关键要找出每个排序一次迭代的代码,然后在此基础上修改。相似题:Insert or Merge

#include <stdio.h>
#include <stdlib.h>
typedef int ElementType;
int N, CopyA[105], B[105], IsInsertion = 0;
int IsIdentical(int arr[]) {    //判别改变后的数组是否与B数组相同
	for(int i = 0; i < N; i++)
		if( arr[i] != B[i] )
			return 0;
	return 1;
}
void Insertion_Sort(int A[]){
	int Tmp, P, i, flag = 0;
	for( P = 1; P < N; P++){
		Tmp = A[P];
		for( i = P; i > 0 && A[i - 1] > Tmp; i--)	//i--别写成i++; 因为是从后往前比较(错误原因)
			A[i] = A[i - 1];
		A[i] = Tmp;
		//如果相同,说明是插入排序,再做一个迭代就退出
		if( IsIdentical(A) ) {
			printf("Insertion Sort\n");
			IsInsertion = 1;	//如果不是,就转去判别是否是归并
			flag = 1;
			continue;
		}
		if(flag) break;		//再做一次迭代就退出
	}
}
void PercDown( ElementType A[], int p, int N ) {
	//将N个元素的数组中以A[p]为根的子堆调整为最大堆
	int Parent, Child;
	ElementType X;
	X = A[p];	//取出根结点存放的值
	//(Parent * 2 + 1) < N 检测Parent有没有孩子
	for( Parent = p; (Parent * 2 + 1) < N; Parent = Child ) {
		Child = Parent * 2 + 1;
		if( Child != N - 1 && A[Child] < A[Child + 1] )
			Child++;	//Child指向左右子结点较大者
		if( X >= A[Child] ) break;
		else	//下滤
			A[Parent] = A[Child];
	}
	A[Parent] = X;
}
void Swap( int *a, int *b ) {
	int tmp = *a;
	*a = *b;
	*b = tmp;
}
void Heap_Sort( ElementType A[], int N ) {
	int i, flag = 0;
	//建立最大堆,由于下标从0开始,最后一个元素的父结点是 N / 2 - 1
	for( i = N / 2 - 1; i >= 0; i--)	
		PercDown(A, i, N);
	//删除堆顶
	for( i = N - 1; i > 0; i-- ) {
		Swap(&A[0], &A[i]);
		PercDown(A, 0, i);
		//判别
		if( IsIdentical(CopyA) ) {
			printf("Heap Sort\n");
			flag = 1;
			continue;
		}
		if(flag) break;
	}
}
int main(){
	int A[105];
	scanf("%d", &N);
	//read
	for(int i = 0; i < N; i++) {
		scanf("%d", &A[i]);
		CopyA[i] = A[i];
	}
	for(int i = 0; i < N; i++)
		scanf("%d", &B[i]);
	//judge
	Insertion_Sort(A);
	if(IsInsertion) {
		printf("%d", A[0]);
		for(int i = 1; i < N; i++)
			printf(" %d", A[i]);
	}
	else {
		Heap_Sort(CopyA, N);
		printf("%d", CopyA[0]);
		for(int i = 1; i < N; i++)
			printf(" %d",CopyA[i]);
	}
	system("pause");
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值