UVA1584-Circular Sequence(紫书例题3.6)

Some DNA sequences exist in circular forms as in

the following gure, which shows a circular sequence

\CGAGTCAGCT", that is, the last symbol \

T

" in

\

CGAGTCAGCT

" is connected to the rst symbol \

C

". We al-

ways read a circular sequence in the clockwise direction.

Since it is not easy to store a circular sequence in a com-

puter as it is, we decided to store it as a linear sequence.

However, there can be many linear sequences that are ob-

tained from a circular sequence by cutting any place of the

circular sequence. Hence, we also decided to store the linear

sequence that is lexicographically smallest among all linear

sequences that can be obtained from a circular sequence.

Your task is to nd the lexicographically smallest sequence

from a given circular sequence. For the example in the gure,

the lexicographically smallest sequence is \

AGCTCGAGTC

". If there are two or more linear sequences that

are lexicographically smallest, you are to nd any one of them (in fact, they are the same).

Input

The input consists of

T

test cases. The number of test cases

T

is given on the rst line of the input

le. Each test case takes one line containing a circular sequence that is written as an arbitrary linear

sequence. Since the circular sequences are DNA sequences, only four symbols, `

A

', `

C

', `

G

' and `

T

', are

allowed. Each sequence has length at least 2 and at most 100.

Output

Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence

for the test case.

Sample Input

2

CGAGTCAGCT

CTCC

Sample Output

AGCTCGAGTC

CCCT

//思路:利用strcmp函数比较字典序,如果找到小的就复制过去,然后将节点向后移一位,继续比较;

#include<iostream>
#include<algorithm>
#include<string>
#include<cmath>
#include<cstdio>
#include<cstring>
using namespace std;
int main() 
{
	char s[110],s1[110];   
	int t;
	cin>>t;
	while(t--)
	{
		cin>>s;
		int l=strlen(s);
		strcpy(s1,s);             //先将s复制到s1数组 
		for(int i=0;i<l;i++)
		{
			char lastc=s[l-1];   //最后一个字符,待会儿赋值给s[0] 
			for(int j=l-1;j>0;j--)
				s[j]=s[j-1];     //相当于往后断开一个节点 
			s[0]=lastc;
			if(strcmp(s,s1)<0)   //如果新串字典序较小,复制给s1 
				strcpy(s1,s);
		}
		cout<<s1<<endl;
	}
	return 0;
}

标程:

#include<stdio.h>
#include<string.h>
#define maxn 105

// 环状串s的表示法p是否比表示法q的字典序小
int less(const char* s, int p, int q) {
  int n = strlen(s);
  for(int i = 0; i < n; i++)
    if(s[(p+i)%n] != s[(q+i)%n])
      return s[(p+i)%n] < s[(q+i)%n];
  return 0; // 相等
}

int main() {
  int T;
  char s[maxn];
  scanf("%d", &T);
  while(T--) {
    scanf("%s", s);
    int ans = 0;
    int n = strlen(s);
    for(int i = 1; i < n; i++)
      if(less(s, i, ans)) ans = i;
    for(int i = 0; i < n; i++)
      putchar(s[(i+ans)%n]);
    putchar('\n');
  }
  return 0;
}

 

转载于:https://www.cnblogs.com/aerer/p/9931045.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值