hdu 4585 Shaolin treap

Shaolin

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)


Problem Description
Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account.
When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.
The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.
 

 

Input
There are several test cases.
In each test case:
The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000)
The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.
The input ends with n = 0.
 

 

Output
A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old monk's id.
 

 

Sample Input
3 2 1 3 3 4 2 0
 

 

Sample Output
2 1 3 2 4 2
 

 

Source
题意:找到最接近x的id;
思路:set二分可以写,练习treap;
#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define pi (4*atan(1.0))
#define eps 1e-14
const int N=1e5+10,M=1e6+10,inf=2147483647;
const ll INF=1e18+10,mod=2147493647;
struct Treap {
    struct node {
        node *son[2];
        int key,siz,wei,cnt,ID;
        node(int _key,int _ID,node *f) {
            son[0]=son[1]=f;
            ID=_ID,key=_key;siz=cnt=1;wei=rand();
        }
        void pushup() {
            siz=son[0]->siz+son[1]->siz+cnt;
        }
    }*null,*root;
    Treap() {
        null=new node(0,0,0);
        null->siz=null->siz=0;
        null->wei=inf;root=null;//  INF视情况而定
    }
    void rot(node* &rt,bool d) {
        node* c=rt->son[!d];rt->son[!d]=c->son[d];
        c->son[d]=rt;rt->pushup();c->pushup();rt=c;
    }
    void insert(const int &key,const int &ID,node* &rt) {
        if (rt==null) {
            rt=new node(key,ID,null);return ;
        }
        /*if (key==rt->key) {
            rt->cnt++;rt->siz++;return ;
        }*/
        bool d=key>rt->key;
        insert(key,ID,rt->son[d]);
        if (rt->wei>rt->son[d]->wei) rot(rt,!d);
        rt->pushup();
    }
    void remove(const int &key,node* &rt) {
        if (rt==null) return ;
        bool d=key>rt->key;
        if (key==rt->key) {
            if (rt->cnt>1) {
                rt->cnt--;rt->siz--;return ;
            }
            d=rt->son[0]->wei>rt->son[1]->wei;
            if (rt->son[d]==null) {
                delete rt;rt=null;return ;
            }
            rot(rt,!d);remove(key,rt->son[!d]);
        } else remove(key,rt->son[d]);
        rt->pushup();
    }
    node* select(int k,node* rt) {
        int s=rt->son[0]->siz+rt->cnt;
        if (k>=rt->son[0]->siz+1&&k<=s) return rt;
        if (s>k) return select(k,rt->son[0]);
        else return select(k-s,rt->son[1]);
    }
    int rank(const int &key,node* rt) {
        if (rt==null) return 0;
        int s=rt->son[0]->siz+rt->cnt;
        if (key==rt->key) return rt->son[0]->siz+1;
        if (key<rt->key) return rank(key,rt->son[0]);
        else return s+rank(key,rt->son[1]);
    }
    pair<int,int> pre(const int &k) {
        node* t=root;int ret=0;int ans=0;
        while (t!=null)
        if (t->key<k) ret=t->key,ans=t->ID,t=t->son[1];
        else t=t->son[0];
        return make_pair(ret,ans);
    }
    pair<int,int> sub(const int &k) {
        node* t=root;int ret=0;int ans=0;
        while (t!=null)
        if (t->key>k) ans=t->ID,ret=t->key,t=t->son[0];
        else t=t->son[1];
        return make_pair(ret,ans);
    }
};
#define par pair<int,int>
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)break;
        Treap tree;
        tree.insert(1000000000,1,tree.root);
        tree.insert(-(1e9),-1,tree.root);
        while(n--)
        {
            int id,x;
            scanf("%d%d",&id,&x);
            printf("%d ",id);
            par p=tree.pre(x);
            par q=tree.sub(x);
            if(abs(p.first-x)<=abs(q.first-x))
                printf("%d\n",p.second);
            else
                printf("%d\n",q.second);
            tree.insert(x,id,tree.root);
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/jhz033/p/6248216.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值