Shaolin

Shaolin

Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account.
When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.
The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.
Input
There are several test cases.
In each test case:
The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk’s id and his fighting grade.( 0<= k ,g<=5,000,000)
The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.
The input ends with n = 0.
Output
A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk’s id first ,then the old monk’s id.
Sample Input

3
2 1
3 3
4 2
0

Sample Output

2 1
3 2
4 2

题意:每个和尚根比自己之前进的相近战力的和尚打,找出和尚的比武顺序
题解:每个和尚用map确定位序然后用二分查找和他相近战力的和尚

#include<iostream>
#include<stack>
#include<queue>
#include<map>
#include<algorithm>
#include<string>

using namespace std;
const int maxn = 1e9;

int main(void) {
    int n;
    while (cin >> n && n) {
        map<int, int> m;
        m[maxn] = 1;
        while (n--) {
            int k, g;
            cin >> k >> g;
            map<int, int>::iterator it = m.lower_bound(g);
            if (it == m.begin()) cout << k << " " << it->second << endl;
            else {
                map<int, int>::iterator x = it, y = --it;
                if (x->first - g >= g - y->first) { // 比他先进去的大于等于的人比武并且还是战力最接近的
                    cout << k << " " << y->second << endl;
                } else {
                    cout << k << " " << x->second << endl;
                }
            }
            m[g] = k;
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
优化下列代码 if arg == 103 then if GetMenPai(sceneId, selfId) ~= 9 then x990010_MsgBox( sceneId, selfId, targetId, "你已是别的门派的高徒了,我们不收你。" ) return end LuaFnJoinMenpai(sceneId, selfId, targetId, MP_SHAOLIN) LuaFnSetXinFaLevel(sceneId,selfId,1,30) LuaFnSetXinFaLevel(sceneId,selfId,2,30) LuaFnSetXinFaLevel(sceneId,selfId,3,30) LuaFnSetXinFaLevel(sceneId,selfId,4,30) LuaFnSetXinFaLevel(sceneId,selfId,5,30) LuaFnSetXinFaLevel(sceneId,selfId,6,30) --LuaFnSetXinFaLevel(sceneId,selfId,55,60) --LuaFnSetXinFaLevel(sceneId,selfId,72,60) LuaFnSendSpecificImpactToUnit(sceneId, selfId, selfId, selfId, 148, 0) local nam = LuaFnGetName( sceneId, selfId ) BroadMsgByChatPipe( sceneId, selfId, "#cFF0000[门派公告]:#c66ccff["..nam.."]#P已经加入了"..x990010_g_mpInfo[arg-101][1].."!", 4 ) CallScriptFunction( 999994, "ActionSkill",sceneId, selfId, -1 ) x990010_ooo( sceneId, selfId) end if arg == 104 then if GetMenPai(sceneId, selfId) ~= 9 then x990010_MsgBox( sceneId, selfId, targetId, "你已是别的门派的高徒了,我们不收你。" ) return end LuaFnJoinMenpai(sceneId, selfId, targetId, MP_TIANSHAN) LuaFnSetXinFaLevel(sceneId,selfId,43,30) LuaFnSetXinFaLevel(sceneId,selfId,44,30) LuaFnSetXinFaLevel(sceneId,selfId,45,30) LuaFnSetXinFaLevel(sceneId,selfId,46,30) LuaFnSetXinFaLevel(sceneId,selfId,47,30) LuaFnSetXinFaLevel(sceneId,selfId,48,30) --LuaFnSetXinFaLevel(sceneId,selfId,62,60) --LuaFnSetXinFaLevel(sceneId,selfId,79,60) LuaFnSendSpecificImpactToUnit(sceneId, selfId, selfId, selfId, 148, 0) local nam = LuaFnGetName( sceneId, selfId ) BroadMsgByChatPipe( sceneId, selfId, "#cFF0000[门派公告]:#c66ccff["..nam.."]#P已经加入了"..x990010_g_mpInfo[arg-101][1].."!", 4 ) CallScriptFunction( 999994, "ActionSkill",sceneId, selfId, -1 ) x990010_ooo( sceneId, selfId) end
最新发布
05-19

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值