HDU OJ How to Type

How to Type

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 45   Accepted Submission(s) : 29
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description

Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

Input

The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

Output

For each test case, you must output the smallest times of typing the key to finish typing this string.

Sample Input
3
Pirates
HDUacm
HDUACM
Sample Output
8
8
8

<div style='font-family:Times New Roman;font-size:14px;background-color:F4FBFF;border:#B7CBFF 1px dashed;padding:6px'><div style='font-family:Arial;font-weight:bold;color:#7CA9ED;border-bottom:#B7CBFF 1px dashed'><i>Hint</i></div>
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
</div>
分析:输入以字符串,求最少需要敲多少下键盘才能完成输入!dp[i][0],dp[i][1]分别记录灯亮时输入第i个字符所敲键盘的次数,灯灭时输入第i个字符时所敲键盘的次数!状态转移方程参见代码!
代码如下:

#include<iostream>
#include <cstring>
#include <cstdio>

using namespace std;

int main()
{
    int i,n;
    char str[105];
    int len;
    int dp[105][2];
    int Min;
    cin>>n;
    while(n--)
    {
        cin>>str+1;
        memset(dp,0,sizeof(dp));
        dp[0][1]=1;
        len=strlen(str+1);
        for(i=1;i<=len;i++)
        {
            if(str[i]>='a' && str[i]<='z')
            {
                dp[i][0]=min(dp[i-1][0]+1,dp[i-1][1]+2);
                dp[i][1]=min(dp[i-1][0]+2,dp[i-1][1]+2);
            }
            else
            {
                dp[i][0]=min(dp[i-1][0]+2,dp[i-1][1]+2);
                dp[i][1]=min(dp[i-1][0]+2,dp[i-1][1]+1);
            }
        }
        dp[len][1]++;
        Min=dp[len][0]<dp[len][1]?dp[len][0]:dp[len][1];
        cout<<Min<<endl;
    }
    return 0;
}

转载于:https://www.cnblogs.com/lzmfywz/articles/2356493.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值