【DP|水】HDU-2577 How to Type

69 篇文章 0 订阅

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
  
  
3 Pirates HDUacm HDUACM
 

Sample Output
  
  
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
 
————————————————————————————————————————————————————————
题意:输入一个仅有大小写字母的字符串,打字的时候通过CapsLock键和Shift键来输入,求最少敲键次数。如果最后CapsLock是on的话还要关掉它。
把题意不清楚的地方澄清一下:
1)不能够按住Shift键输入多个字母
2)在CapsLock on的情况下,按Shift键输入的是小写字母
设dp[0][i]为CapsLock off的情况下输入第 i个字符时总敲键次数
dp[1][i]为CapsLock on……
状态转移方程很容易想。
代码如下:
/**
 * ID: j.sure.1
 * PROG:
 * LANG: C++
 */
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <climits>
#include <iostream>
#define Mem(f, x) memset(f, x, sizeof(f))
#define Pb push_back
#define LL long long
using namespace std;
const int INF = 0x3f3f3f3f;
const double eps = 1e-8;
/****************************************/
const int N = 111;
char str[N];
int dp[2][N];

int main()
{
#ifdef J_Sure
    freopen("000.in", "r", stdin);
    //freopen("999.out", "w", stdout);
#endif
    int T;
    scanf("%d", &T);
    while(T--) {
        scanf("%s", str);
        int len = strlen(str);
        if(str[0] >= 'a') {
            dp[0][0] = 1;
            dp[1][0] = 3;
        }
        else {
            dp[0][0] = 2;
            dp[1][0] = 2;
        }
        for(int i = 1; i < len; i++) {
            if(str[i] >= 'a') {
                dp[0][i] = min(dp[0][i-1] + 1, dp[1][i-1] + 2);
                dp[1][i] = min(dp[0][i-1] + 3, dp[1][i-1] + 2);
            }
            else {
                dp[0][i] = min(dp[0][i-1] + 2, dp[1][i-1] + 3);
                dp[1][i] = min(dp[0][i-1] + 2, dp[1][i-1] + 1);
            }
        }
        int ans = min(dp[0][len-1], dp[1][len-1] + 1);
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值