ZOJ 1539 L-Lot

https://vjudge.net/contest/67836#problem/L

 

Out of N soldiers, standing in one line, it is required to choose several to send them scouting. 
In order to do that, the following operation is performed several times: if the line consists of more than three soldiers, then all soldiers, standing on even positions, or all soldiers, standing on odd positions, are taken away. The above is done until three or less soldiers are left in the line. They are sent scouting. Find, how many different groups of three scouts may be created this way.

Note: Groups with less than three number of soldiers are not taken into consideration.

0 < N <= 10 000 000

 

Input

The input file contains the number N.

Process to the end of file.


Output

 

The output file must contain the solution - the amount of variants.


Sample Input

10
4

Sample Output

2
0

时间复杂度:$O(n)$

 代码1:

#include<bits/stdc++.h>
using namespace std;

const int maxn = 1e7 + 10;
int num[maxn];

int main()
{
    for(int i = 1; i <= 10000000; i ++) {
        if(i < 3) num[i] = 0;
        else if(i == 3) num[i] = 1;
        else if(i % 2 == 0) num[i] = 2 * num[i / 2];
        else num[i] = num[i / 2] + num[i / 2 + 1];
    }

    int n;
    while (~scanf("%d", &n))
        printf("%d\n", num[n]);
    return 0;
}

 

转载于:https://www.cnblogs.com/zlrrrr/p/9529244.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值