ZOJ 1539(ZZULI 1606) LOT (递…

Lot

Time Limit: 2 Seconds         Memory Limit: 65536 KB

Out of N soldiers, standing in one line, it is required to choose several to send them scouting.
In order to do that, the following operation is performed several times: if the line consists of more than three soldiers, then all soldiers, standing on even positions, or all soldiers, standing on odd positions, are taken away. The above is done until three or less soldiers are left in the line. They are sent scouting. Find, how many different groups of three scouts may be created this way.

Note: Groups with less than three number of soldiers are not taken into consideration.

0 < N <= 10 000 000


Input

The input file contains the number N.

Process to the end of file.


Output

The output file must contain the solution - the amount of variants.


Sample Input

10
4


Sample Output

2
0

其实可以递推的题一般都可以用递归解决的

 

题意:给你一个n排成一列,可以取出奇数位的数,也可以取出偶数位的数,求最终使队列里面要剩下三个数有多少种取法

 

我用了递归,虽然比较耗时,但是还好没超时,代码比较简单明了,就不说了

 

代码:

#include<stdio.h>

int num;

void DFS( int n)
{
      if(n == 3 ){ num ++; return ;}
      if(n < 3) return;
      if(n % 2 == 0)
      {
              DFS(n / 2);
              DFS(n / 2);
      }
      else {
              DFS(n / 2);
              DFS(n / 2 + 1);
      }
}
int main()
{
      int n;
      while( scanf( "%d" , &n) != EOF)
      {
              num = 0;
              DFS(n);
              printf( "%d \n " , num);
      }
      return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值