zoj 1539 Lot 简单DP 记忆化

26 篇文章 0 订阅
14 篇文章 0 订阅
Lot

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Out of N soldiers, standing in one line, it is required to choose several to send them scouting.
In order to do that, the following operation is performed several times: if the line consists of more than three soldiers, then all soldiers, standing on even positions, or all soldiers, standing on odd positions, are taken away. The above is done until three or less soldiers are left in the line. They are sent scouting. Find, how many different groups of three scouts may be created this way.

Note: Groups with less than three number of soldiers are not taken into consideration.

0 < N <= 10 000 000


Input

The input file contains the number N.

Process to the end of file.


Output

The output file must contain the solution - the amount of variants.


Sample Input

10
4


Sample Output

2
0

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int f[10000001];
int _find(int v)
{
	if(v<3) return f[v]=0;
	if(v==3) return f[v]=1;
	if(f[v]>0) return f[v];
	if(v%2==0)  return f[v]=_find(v/2)*2;
	else  return f[v]=_find(v/2)+_find(v/2+1);
}
int main()
{
	int n,s;
	while(cin>>n)//不知道为什么,这里换成输入优化就超超时了。。。。。。求大佬告知
	{
		s=_find(n);
		if(s>0)
		printf("%d\n",s);
		else printf("0\n");
	}
	return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值