统计字母数字等个数

Problem Description

输入一串字符,统计这串字符里的字母个数,数字个数,空格字数以及其他字符(最多不超过100个字符)

Input

多组测试数据,每行一组

Output

每组输出一行,分别是字母个数,数字个数,空格字数以及其他字符个数

Sample Input

I am a student in class 1.
I think I can!

Sample Output

18 1 6 1
10 0 3 1




源代码如下:

#include <iostream>
#include<cctype>
using namespace std;

 char s[100];
int main()
{
    int alpha,num,space,other;
   while(gets(s))
   {
       alpha=0,num=0,space=0,other=0;
       for(int i=0;s[i]!='\0';++i)
       {
           if(isalpha(s[i]))      ++alpha;
           else if(isdigit(s[i])) ++num;
           else if(s[i]==32)      ++space;
           else                   ++other;
       }
       cout<<alpha<<" "<<num<<" "<<space<<" "<<other<<endl;
   }
    return 0;
}


转载于:https://www.cnblogs.com/yldf/p/6249938.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值