POJ3273:Monthly Expense(二分)

Monthly Expense
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 9302Accepted: 3823

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤moneyi ≤ 10,000) that he will need to spend each day over the nextN (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactlyM (1 ≤MN) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers:N andM
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on theith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

Source

MYCode:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define MAX 100010
int v[MAX];
int sum;
int n,m;
int most;
bool check(int lim)
{
    int i;
    int s=0;
    int ct=0;
    for(i=1;i<=n;i++)
    {
        if(s+v[i]<=lim)
        s+=v[i];
        else
        {
            ct++;
            s=v[i];
        }
    }
    ct++;
    if(ct<=m)
    return true;
    return false;
}

int search()
{
    int lt=most,rt=sum;
    while(lt<rt)
    {
        int mid=(lt+rt)/2;
        if(check(mid))
        rt=mid;
        else
        lt=mid+1;
    }
    return rt;
}
int main()
{
    while(scanf("%d%d",&n,&m)!= EOF)
    {
        int i;
        sum=0;
        most=-1;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&v[i]);
            sum+=v[i];
            if(v[i]>most)
            most=v[i];
        }
        int ans=search();
        printf("%d\n",ans);
    }
}

//63MS
二分法,复杂度nlogn

转载于:https://www.cnblogs.com/java20130725/archive/2012/11/27/3215880.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值