FOJ ——Problem 1759 Super A^B mod C

 Problem 1759 Super A^B mod C

Accept: 1368    Submit: 4639
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,C<=1000000000,1<=B<=10^1000000).

 Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

 

 Output

For each testcase, output an integer, denotes the result of A^B mod C.

 

 Sample Input

3 2 4 2 10 1000

 Sample Output

1 24
 
 
题意:求(a^b)%c的值,由于是mod一个数,数据范围又非常大,我们非常容易想到循环节这个东西
那么我们就可以根据一个数学公式

求出c的欧拉函数,最后再求快速幂,就可以得到long long范围内的结果了

tips:FOJ不支持万能头文件和%lld

http://acm.fzu.edu.cn/problem.php?pid=1759

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1e6+5;
typedef long long ll;
char str[maxn];
int phi(int n){
    int rea=n;
    for(int i=2;i*i<=n;i++){
        if(n%i==0){
            rea=rea-rea/i;
            while(n%i==0) n/=i;
        }
    }
    if(n>1) rea=rea-rea/n;
    return rea;
}
ll multi(ll a,ll b,ll m){
    ll ans=0;
    a%=m;
    while(b){
        if(b&1){
            ans=(ans+a)%m;
            b--;
        }
        b>>=1;
        a=(a+a)%m;
    }
    return ans;
}
 
ll quick_mod(ll a,ll b,ll m){
    ll ans=1;
    a%=m;
    while(b){
        if(b&1){
            ans=multi(ans,a,m);
            b--;
        }
        b>>=1;
        a=multi(a,a,m);
    }
    return ans;
}
void solve(ll a,char str[],ll c){
    ll len=strlen(str);
    ll ans=0;
    ll p=phi(c);
    if(len<=15){
        for(int i=0;i<len;i++){
            ans=ans*10+str[i]-'0';
        }
    }else{
        for(int i=0;i<len;i++){
            ans=ans*10+str[i]-'0';
            ans%=p;
        }
        ans+=p;
    }
    printf("%I64d\n",quick_mod(a,ans,c));
}
int main(){
    ll a,c;
    while(~scanf("%I64d%s%I64d",&a,str,&c)){
        solve(a,str,c);
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/buerdepepeqi/p/9147472.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值