[FOJ 1752] A^B mod C

Problem 1752 A^B mod C

Accept: 750    Submit: 3205
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,B,C<2^63).

 Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

 Output

For each testcase, output an integer, denotes the result of A^B mod C.

 Sample Input

3 2 4 2 10 1000

 Sample Output

1 24
 
二分快速幂模板题
#include <iostream>
#include <cstdio>
using namespace std;
#define ll __int64

ll quickadd(ll a,ll b,ll c)    //运用快速幂的思想快速加,这样就不会溢出
{
    ll ret=0;
    while(b)
    {
        if(b&1)
        {
            ret+=a; 
            if(ret>=c) ret-=c; //这样比直接取模(ret%=c)更快
        }
        a<<=1;
        if(a>=c) a-=c;
        b>>=1;
    }
    return ret;
}
ll quickpow(ll a,ll b,ll c)
{
    ll ret=1;
    while(b)
    {
        if(b&1) ret=quickadd(a,ret,c);
        a=quickadd(a,a,c);
        b>>=1;
    }
    return ret;
}
int main()
{
    ll a,b,c;
    while(scanf("%I64d%I64d%I64d",&a,&b,&c)!=EOF)
    {
        printf("%I64d\n",quickpow(a%c,b,c));
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/hate13/p/4123380.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值