[USACO16OPEN]关闭农场Closing the Farm(洛谷 3144)

题目描述

Farmer John and his cows are planning to leave town for a long vacation, and so FJ wants to temporarily close down his farm to save money in the meantime.

The farm consists of  barns connected with  bidirectional paths between some pairs of barns (). To shut the farm down, FJ plans to close one barn at a time. When a barn closes, all paths adjacent to that barn also close, and can no longer be used.

FJ is interested in knowing at each point in time (initially, and after each closing) whether his farm is "fully connected" -- meaning that it is possible to travel from any open barn to any other open barn along an appropriate series of paths. Since FJ's farm is initially in somewhat in a state of disrepair, it may not even start out fully connected.

FJ和他的奶牛们正在计划离开小镇做一次长的旅行,同时FJ想临时地关掉他的农场以节省一些金钱。

这个农场一共有被用M条双向道路连接的N个谷仓(1<=N,M<=3000)。为了关闭整个农场,FJ 计划每一次关闭掉一个谷仓。当一个谷仓被关闭了,所有的连接到这个谷仓的道路都会被关闭,而且再也不能够被使用。

FJ现在正感兴趣于知道在每一个时间(这里的“时间”指在每一次关闭谷仓之后的时间)时他的农场是否是“全连通的”——也就是说从任意的一个开着的谷仓开始,能够到达另外的一个谷仓。注意自从某一个时间之后,可能整个农场都开始不会是“全连通的”。

输入输出格式

输入格式:

 

The first line of input contains  and . The next  lines each describe a

path in terms of the pair of barns it connects (barns are conveniently numbered

). The final  lines give a permutation of 

describing the order in which the barns will be closed.

 

输出格式:

 

The output consists of  lines, each containing "YES" or "NO". The first line

indicates whether the initial farm is fully connected, and line  indicates

whether the farm is fully connected after the th closing.

 

输入输出样例

输入样例#1:
4 3
1 2
2 3
3 4
3
4
1
2
输出样例#1:
YES
NO
YES
YES

/*
  每删一个点,用宽搜灌水法求是否联通。
*/
#include<cstdio>
#include<iostream>
#include<queue>
#include<cstring>
#define M 3010
using namespace std;
int head[M],clo[M],vis[M],n,m;
struct node
{
    int v,pre;
};node e[M*2];
void add(int i,int x,int y)
{
    e[i].v=y;
    e[i].pre=head[x];
    head[x]=i;
}
bool bfs(int s)
{
    memset(vis,0,sizeof(vis));
    queue<int> q;
    q.push(s);vis[s]=1;
    while(!q.empty())
    {
        int u=q.front();q.pop();
        for(int i=head[u];i!=-1;i=e[i].pre)
          if(!vis[e[i].v]&&!clo[e[i].v])
          {
              vis[e[i].v]=1;
              q.push(e[i].v);
          }
    }
    for(int i=1;i<=n;i++)
      if(!clo[i]&&!vis[i])return false;
    return true;
}
int main()
{
    memset(head,-1,sizeof(head));
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        add(i*2-2,x,y);add(i*2-1,y,x);
    }
    for(int t=1;t<=n;t++)
    {
        for(int i=1;i<=n;i++)
          if(!clo[i])
          {
              if(bfs(i))printf("YES\n");
              else printf("NO\n");
              break;
          }
        int x;scanf("%d",&x);
        clo[x]=1;
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/harden/p/5883133.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值