poj-3041-Asteroids

poj-3041-Asteroids

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24115 Accepted: 13066

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

 

 

17919386 3041Accepted1408K16MSG++721B2017-12-04 21:25:29

 

 

使用匈牙利算法。

典型的匈牙利算法,建立二分图模型。

 

 

// poj 3041 hungary 

#include <cstdio>  
#include <cstring> 

const int MAXN = 500 + 10; 

int n, k, mp[MAXN][MAXN], vis[MAXN], match[MAXN]; 

bool dfs(int x){ 
	for(int i=1; i<=n; ++i){
		if( mp[x][i] != 0 && vis[i] == 0 ){
			vis[i] = 1; 
			if(match[i] < 0 || dfs(match[i])){
				match[i] = x;
				return true;  
			}
		}
	}
	return false; 
}

int main(){
	freopen("in.txt", "r", stdin); 

	int num, x, y; 
	while(scanf("%d %d", &n, &k) != EOF){
		memset(mp, 0, sizeof(mp)); 

		for(int i=0; i<k; ++i){
			scanf("%d %d", &x, &y);
			mp[x][y] = 1;  
		} 

		num = 0; 
		memset(match, -1, sizeof(match)); 

		for(int i=1; i<=n; ++i){ 
			memset(vis, 0, sizeof(vis)); 
			if( dfs( i ) ){
				++num; 
			} 
		} 
		printf("%d\n", num );
	}
	return 0; 
}

  

 

转载于:https://www.cnblogs.com/zhang-yd/p/7979081.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值