UVa - 10339

It has been said that a watch that is stopped keeps better time than one that loses 1 second per day.
The one that is stopped reads the correct time twice a day while the one that loses 1 second per day
is correct only once every 43,200 days. This maxim applies to old fashioned 12-hour analog watches,
whose hands move continuously (most digital watches would display nothing at all if stopped).
Given two such analog watches, both synchronized to midnight, that keep time at a constant rate
but run slow by k and m seconds per day respectively, what time will the watches show when next they
have exactly the same time?
Input
Input consists of a number of lines, each with two distinct non-negative integers k and m between 0
and 256, indicating the number of seconds per day that each watch loses.
Output
For each line of input, print k, m, and the time displayed on each watch, rounded to the nearest minute.
Valid times range from 01:00 to 12:59.
Sample Input
1 2
0 7
Sample Output
1 2 12:00
0 7 10:17

解题思路:

题意:

有两个表每天分别慢a,b秒,要求当这两个表重合的时候,A钟的时间;

思路:

首先要求两表重合,那么两表相差的时间必为12个小时: 43200/abs(a-b),求出所需的天数;

下一步则要求钟A此时走了多少秒  day*(86400-n); 因为这是表a记录的时间,所以要减去表a一天慢的秒数

最后就是时间的转换了;

实现代码:

#include<cstdio>
#include<cmath>
using namespace std;
#define ll long long
int main()
{
    int a,b;
    while(scanf("%d%d",&a,&b)!=EOF){
        int ans = abs(a-b);
        double  day = 43200.0/ans;
        ll tA = (ll)(day*(86400-a));
        tA = tA%43200;
        int min = tA/60;
        tA%=60;
        if(tA >= 30) min++;
        int hour = min/60;
        min %= 60;
        if(hour == 0)
            hour = 12;
        printf("%d %d %02d:%02d\n", a,b, hour, min );
    }
}

 

转载于:https://www.cnblogs.com/kls123/p/7112199.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值